This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Alejandro 4 weeks, 1 day ago.

Assigned support staff: Alejandro.

Author Posts
September 11, 2019 at 7:20 am #4551061

oscarM-16

I am trying to: Configure wpml to display default language post when no translation available

Link to a page where the issue can be seen: hidden link

I expected to see: The default language posts

Instead, I got: Nothing

September 11, 2019 at 8:30 am #4551709

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. You can display posts in default language by selecting ‘Translatable - use translation if available or fallback to default language’ option from WPML >> Settings >> Multilingual Content Setup > Post Types Translation. Which means, If a translation exists WPML displays it, otherwise, it displays content from the site’s default language.

Here is doc for more details:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/#displaying-original-content-for-whole-post-types

If still issue persists, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

September 11, 2019 at 11:44 am #4553051

oscarM-16

It is configured as you said (use translated content, otherwise standard language)

I works in the blog page, but not in the home page, in which blog posts are showed. This home page is displaying post from the category="blog", which is translated with the same name and blog-en slug.

I also have configured categories to use translated categories otherwise std language.

This section is configured in theme options, and the option set for the category blog (=3) is retrieved from home.php file in theme.

Thanks a lot!

September 11, 2019 at 4:26 pm #4555275

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 12, 2019 at 4:36 pm #4563401

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have tried to open your site but it showing ‘This site can’t be reached’ issue as you can see in the attached screenshot. Could you please let me know how can I access this site?

Thank you

September 13, 2019 at 6:44 am #4565887

oscarM-16

Sorry, its hidden link

September 15, 2019 at 8:37 am #4574181

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I can access the site now but wp-login info that you have provided is not working here. Could you please provide me working login. I have enabled private input box for your next reply.

Thank you

September 18, 2019 at 10:55 am #4595347

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, my name is Alejandro,

Since Noman is currently not available, I will replace him here in the forum.

I hope this is OK with you.

I checked the site and i wanted to check your site but i can't access the site through FTP (i could access the WordPress dashboard, though.

I see what you mean and i know that coding the best approach would take way too much time and it wouldn't be worth the while since it would probably have a lot of bugs.

So i'll offer you another solution.

- Go to your WPML > Settings > Post Types Translation > Set your posts to: Translatable - only show translated items

- Then go to WPML > Translation management > find your untranslated posts and select them all and then duplicate them (you can also do this independently in pages > all pages > access the page you want to duplicate and duplicate it).

See, the problem here is that these systems use filters in order to know what to choose, and since there aren't elements in the English language (i.e: no posts), the filter doesn't find anything and doesn't show anything.

If you wanted to code a way around this you'd end up having shown elements from both languages which is good but then you could have SEO issues which is not good. that's why i believe that the best option is what i just suggested.

with this suggestion you'd just have to take this etra step and that's it. everytime you updated a post, its duplicate would update itself as well without issues.

Regards.