Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by hooiC 11 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 8, 2019 at 4:04 pm #3294034

hooiC

I am trying to: the default langauge is English, the language switcher has the full set of languages. then click on "Trying for a baby" on the menu, the language switcher only has Irish ( which is a duplicate of english). how can we get back all the languages on the switcher.

Link to a page where the issue can be seen: see images.

I expected to see:

Instead, I got:

March 8, 2019 at 6:06 pm #3294854

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. The language switcher only shows the languages the page is translated in otherwise it will omit the language flag/name. Please, make sure you have translations in all the langauges available for the mentioned page.

See: https://wpml.org/documentation/getting-started-guide/

If you still need to show all the language flags/names even without a translation then you can set it at your WordPress Dashboard > WPML > Languages > Language switcher options settings.

See: https://wpml.org/documentation/getting-started-guide/language-setup/#language-switcher

Please, let me know if you need any additional details. Have a nice day.

March 8, 2019 at 6:12 pm #3294928

hooiC

Hi Marcos. i don't think you understand the issue. all the languages are translated and you can see the languages on the switcher. but I am saying there is a problem when you click on english. you select a subject on the menu and if you look at the language switcher, you can only see Irish. please can you try on our dev site. if you click on one of the language you can stilll see all the languages on the switcher.

March 8, 2019 at 7:53 pm #3295342

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 10, 2019 at 10:17 am #3303595

hooiC

HI Marcos please don't make any changes to our development site as its our copy with the language sites on it. if you need to see the back end files, I can't give you ftp access as its with IT consultant. if you need a zip file of the files/folders , please let us know.

March 11, 2019 at 1:28 pm #3313085

hooiC

we updated all the plugins and remove t3 cache. the switcher is working now. My issue is resolved now. Thank you!