This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Riffaz 7 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
March 5, 2019 at 12:32 am #3270941

john-michaelM

Hello,

I speak English (only) but am working on a site where the default language will be Spanish, but some content will exist in English.

When I set the default language to Spanish, the WPML admin pages also become Spanish. That is understandable, but I can't find anywhere to set the admin language to English, either for everyone or just for myself.

I have seen other threads about this, but all the explanations and screen captures appear to be based on older versions of WPML and I can't find corresponding settings.

Can you point me in the right direction?

Thanks

March 5, 2019 at 6:08 am #3271767

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thanks for contacting support, I'll do my best to help you with this! ?

You can change your backend language from Users>Your Profile Language : hidden link

This select field will specify the language used for your backend. Please note that this will be only applied to the specific user account.
If you want to browse your backend in a different language with a different user, you'll need to edit his profile to specify it.
Otherwise the backend will be displayed in the language you used to install WordPress.

And for your front end language you can change / select it here : WPML > Languages > Site Languages > change default language : hidden link

Hope, this will help you.

Let me know.

Regards,
Riffaz.

March 5, 2019 at 10:56 am #3273088

john-michaelM

Thanks, Riffaz

I can change the default language, but on my profile page I do not have a language selector as your image shows. I have attached what I see. (I am the only user on the site at this point)

Thanks

March 5, 2019 at 11:00 am #3273119

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

but on my profile page I do not have a language selector as your image shows.
- This is default WordPress feature.
- not related to WPML or any other plugin.
- so it should be there right after you installed the WordPress
- if not, probably you are not the admin of your site.
- if you are the admin and still you do not see this, this might be a plugin conflict.
- please disable all the plugins and see.

Let me know how it goes.

Regards,

March 5, 2019 at 1:49 pm #3274336

john-michaelM

As I mentioned, I am the only user, so I am the admin of the site.

I disabled ALL plugins except WPML and changed the theme to the WP default, and this is what my profile shows. Still no language selector.

Do you think I need to do something to install more than one language for it to appear?

There is a site language selector on the General Settings page but English is the only choice, and the whole thing is disabled with WPML is enabled.

March 6, 2019 at 12:12 pm #3278791

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

As I explained already it has nothing to do with WPML.
It should be appeared even if you disable the WPML.
This feature comes with WordPress. Not from WPML.
Please refer : hidden link

I suggest you to disable WPML and all other plugins.
Then check the issue.

Also, try to install WordPress in a test site and check.

And, if you have any custom code in your child theme functions.php remove them and check or simply switch your theme to a default theme like twenty seventeen and check.

Regards,

March 6, 2019 at 2:09 pm #3279565

john-michaelM

As I said, I did try your suggested steps.

I also just setup a totally fresh and empty WP install, and attached is a screen cap of my profile page. There is no language selector.

March 6, 2019 at 3:16 pm #3279952

john-michaelM

Update: On another site, same as the one using Spanish, but instead using Italian... after I installed WPML the English/Italian language selector did appear on my profile page. Seems like it's reliant on a language installed by WPML, but I am not sure why it didn't work with Spanish.

Whether the language option appears by default may depend on the WordPress install... and I can tell you at least on Pantheon and Flywheel (managed WordPress hosts) it does not appear with a fresh WP install.

March 7, 2019 at 4:59 am #3282351

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Glad you made a process.

Seems like it's reliant on a language installed by WPML, but I am not sure why it didn't work with Spanish.
- that's the strange part.
- i should work with any languages pair

I can tell you at least on Pantheon and Flywheel (managed WordPress hosts) it does not appear with a fresh WP install
- then this should be discussed with these hosting supports.
- they may have a specific configurations for this.

Let me know if need anything else but please note since it is not WPML related issue it may take some more time to troubleshoot if you have any other questions regarding this.

Regards,

The topic ‘[Closed] Default language vs admin language’ is closed to new replies.