Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The default locale shown for Myanmar (Burmese) in that link is my_MM. I used that locale to create the secondary language I am currently translating into.

However, I found out that that particular language is based on Unicode. There are 2 main types of Burmese fonts (Zawgyi-One (95% of the population uses it) and Unicode (5% of the population uses it)) with different keyboard character arrangements and compatibility with different internet platforms.

For any browser chosen, ONLY one type of Burmese font can be readable.

Solution: Make sure that the font used on the website has support for the myanmar language. Also, make sure that the font you're using is not installed just locally, on the computer used to develop the website. This may cause the issue where the font is looking fine only on one computer.

This topic contains 42 replies, has 3 voices.

Last updated by hlaingM 4 weeks ago.

Assigned support staff: Radu.

Author Posts
April 25, 2019 at 9:55 am #3680777

hlaingM

Hi,

https://make.wordpress.org/polyglots/teams/

The default locale shown for Myanmar (Burmese) in that link is my_MM. I used that locale to create the secondary language I am currently translating into.

However, I found out that that particular language is based on Unicode. There are 2 main types of Burmese fonts (Zawgyi-One (95% of the population uses it) and Unicode (5% of the population uses it)) with different keyboard character arrangements and compatibility with different internet platforms.

I created the secondary language using my_MM with WPML. I have been translating using Zawgyi-One Font. Now, when I transferred translated contents into wp-content>language> and look at the translated contents on different browsers, I found out that if I can read those word-press translated contents translated by others, I cannot read my translated texts. Similarly, if my translated texts appear as eligible texts, those word-press translated contents do NOT appear as eligible texts.

Do I have to create a different name for locale in lieu of my_MM for Zawgyi-One Font? (or) does the other locale name already exist with that Zawgyi-One Font?

Thanks,

April 25, 2019 at 6:31 pm #3685033

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us. I would be very happy to help you but I didn't fully understand what is the issue.

From what I understand the problem basically consists of the font-family you are using. Is that correct?

This may be the configuration of the fonts installed on your computer. Please, would it be possible for you to publish some screenshot so that I can see in more detail what you are saying?

Thank you.

April 25, 2019 at 8:40 pm #3685833

hlaingM

Hi, Thank you for your reply. I am attaching the image. You see the displays of 2 types of fonts (Zawgyi-One and Unicode) on 2 different browsers (left and right).

For any browser chosen, ONLY one type of Burmese font can be readable. I copied the Burmese language fonts from the wordpress link. That's why you see the translation (using unicode) at the bottom of either browser screen. Presumably, the browser on the right browser has the unicode font installed.

https://make.wordpress.org/polyglots/teams/

With that, one can conclude that they used my_MM for locale for texts typed using the unicode font.

I don't want to re-write or add my questions again here to avoid lengthy texts. With those additional info, you can re-read my previous questions. Thank you for your time.

April 27, 2019 at 12:05 am #3693595

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. Because each computer may have different fonts installed, perhaps the best option is to use "Web Fonts", which will load the same font for all users and browsers. For example: hidden link

Anyway, I'll contact 2nd tier support to ask more about this. But if this is a problem from sources, you will need some solution like the use of web fonts.

Thank you.

April 27, 2019 at 2:49 am #3694119

hlaingM

Hi,

Thank you for your response. Absolutely, different computers have a specific but different Burmese font (mainly, Zawgyi or Unicode) installed.

Different fonts also have different character arrangements (type-set) on the keyboard. That creates also another issue with a site like mine that has "search" engine. Zawgyi, the font I am using with WPML, is used by 95% of the population. The font "Padauk", you were referring to, has a different character arrangements than the "Zawgyi". When I tested "Padauk", I found that it has a different type-set than the "Zawgyi".

The best scenerio will be to have "Zawgyi" installed in on my website or a web version of "Zawgyi"(with the same type-set as "Zawgyi" installed on my website. Every time the user visits my website, that font is loaded so that people will be using the same "Zawgyi" font. In that case, we may have to create a different locale than the existing wordpress default locale (my_MM).

Thank you very much. I am awaiting your answer.

April 30, 2019 at 1:12 am #3707073

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Sorry for the delay. Just as test, please, could you disable WPML and see how the fonts are displayed as current?

According to 2nd tier support, this is probably not related to WPML. For this you need to test the behavior of your site without WPML to see how the sources will be displayed.

Thank you.

April 30, 2019 at 9:33 am #3710109

hlaingM

Hi,

I am not sure what "sources" you were referring to? and what to test or check?

I just tested by turning off the WPML plugins. Please note that the (unicode) font with the existing my_MM default wordpress locale cannot be seen as it is the case with the turning on the default English language switch when the WPML plugins are activated.

Apparently, when the WPML plugins are activated and the secondary language switch is on, those default translations (for example, the translation of "pm" time displayed at the footer or in the image of the message box attached earlier) are different from Zawgyi-One (which 95% of the population and I am using for translation with WPML). To repeat what I mentioned earlier, those default translations are NOT displaying correctly if my translations with WPML are displaying correctly. Similary, if those are displaying correctly, my translations with WPML are NOT displaying correctly.

April 30, 2019 at 8:31 pm #3714841

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for the explanation. I will contact 2nd tier support again so they can double-check this.

Thank you.

May 7, 2019 at 5:59 am #3754135

hlaingM

Hi Bruno,

Thank you. I am awaiting your response.

I would like to mention one thing. There are words such as months (January, February, etc) or time (AM or PM) and others that were already translated with the default my_MM that was created with the unicode font different from what I have been using and what the 95% of the population is using. Consequently, EITHER the default font OR the font I use is not being displayed correctly depending on the type of font installed for a specific browser, as I explained earlier.

Thank you and I am awaiting your response.

May 7, 2019 at 8:34 pm #3761817

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Sorry for the delay. About the first problem, how can I check this issue? Is your site already online available so that we can access?

Also, please, what is the version of WPML and WP are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Thank you.

May 7, 2019 at 9:32 pm #3762123

hlaingM

Hi, yes, you can have an access to my account. I attached an example of fonts which I did not translate. In the earliest message to you, I included the image(s) which also displayed the fonts I did not translate. As I already described, those are from your wordpress default unicode fonts different from Zawgyi-One which I have been using on my site and 95% of the population uses.
Wordpress version 5.1.1
Plugin Name Status Active Version
WPML Multilingual CMS Installed Yes 4.2.6
WPML CMS Nav Not installed No n/a
WPML String Translation Installed Yes 2.10.4
WPML Sticky Links Not installed No n/a
WPML Translation Management Installed Yes 2.8.5
WPML Media Installed Yes 2.5.2
WooCommerce Multilingual Installed Yes 4.6.2.1
Gravity Forms Multilingual Not installed No n/a
Yoast SEO Multilingual Not installed No n/a

Thanks.

May 10, 2019 at 2:29 am #3780493

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

First of all, my sincere apologies for the delay. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

May 14, 2019 at 2:06 am #3802497

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. When I try to access your site using the credentials you posted above, this error message is displayed:

ERROR: Invalid username. Lost your password?
Cookies are blocked or not supported by your browser. You must enable cookies to continue.

Please, could you check? You can edit your private message above, which is showing highlighted.

Thank you.

May 14, 2019 at 2:16 am #3802577

hlaingM

Hi,

I checked the credentials which I found to be correct. It is probably caused by your browser or the WPML platform you are probably using. You have to enable your cookies from your side if that is happening. Other people and I can have an access using these credentials.

Please let me know if you still encounter an issue or let me know what I can do to help you with an access to my site. Thank you.

May 14, 2019 at 9:37 pm #3810785

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Although a cookie message appears, this does not appear to be related to cookies, but to the user who is incorrect. I tried accessing Firefox too and the problem is the same. I'll attach an image for you to see.

Maybe you can create another user for me with administrator role and use another password? That way I can try with another user as well.

Thank you.