This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by hlaingM 4 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
May 23, 2019 at 3:47 pm #3877629

hlaingM

Hi,

I set the default locale with WPML. Unfortunately, the default locale/fonts (wordpress built-in translation) have a [unicode] font system different from the font system I am using. The latter is used by the 95% of the population who speaks that language. Some examples of the built-in translations include months (January, February,...), date/time, etc.

The issue is that those built-in translations don't appear correctly in some browsers which has installed the font I am using. It is impossible to use a mix font system. How can I get rid of the built-in translations? (OR) re-translate the files that have those built-in translations, using my font system?

Thank you.

May 24, 2019 at 11:14 am #3884195

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

I am not sure if can understand the scenario here in full, I can imagine that it would be very helpful if you could make at least a basic setup related to your questions. Can you tell me if you would be interested in setting this up on a our clean Sandbox server, as it would help us understand the scenario better?

Regards,
Bruno Kos

May 24, 2019 at 12:56 pm #3884859

hlaingM

Hi,

I am attaching the two images where you can see that the default translations (making use of the unicode font system) included with wordpress are NOT displaying proper characters, whereas my translations which use a different font system are displaying proper characters.

It is because these browsers (shown in the attached image) have my font system installed.

On the other hand, if these browsers have the unicode font system installed, they won't be displaying proper characters for my translations and they will be displaying proper characters for the default wordpress translations.

Now, I want to get rid of those default wordpress translations by replacing them by my translations (using my font system) (or) totally removing those default files responsible for the default wordpress translations.

How can I do that? Thank you.

May 24, 2019 at 1:41 pm #3885339

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you tell me e.g. where is this footer info coming from? Can you perhaps paste this code (it could be in footer.php file) so that I can see it?

Can you tell me if you used String Translation perhaps or are these theme translated strings? They may be somewhere within the text-domain of your theme.

Perhaps it would help if I could check inside your site - therefore, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

May 27, 2019 at 7:06 am #3893891

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you tell me if this is the correct font and/or translation? I have temporarily disabled this setting:
WPML -> Theme and plugins localization -> How to translate strings in themes and plugins? -> Don't use String Translation to translate themes and plugins

Regards,
Bruno Kos

May 27, 2019 at 9:08 am #3895035

hlaingM

Hi,

For about the 5% of the words, the fonts are displayed properly in the browsers with either one of the two font systems.

You happened to pick the wrong sample word (translation of "pm") which belongs in that 5%. It is displayed properly in your browser and also in my browser with a different font system installed.

But, the other 95% of the words/characters on your screenshot are not displayed properly. Apparently, your browser has the unicode font system installed since the words I translated are not displayed properly in your screenshots. Since I did NOT translate that specific word "pm", it can be concluded that that word "pm" originated by default from the wordpress.

Does what I just said make sense to you? My understanding is that if I choose the setting
" Translate themes and plugins using WPML's String Translation only (don't load .mo files)", those default translations will NOT appear. But, that has not been the case.

Thanks.

May 27, 2019 at 2:25 pm #3898275

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

But, the other 95% of the words/characters on your screenshot are not displayed properly

Can you show me 1-2 links for those? It may also help me if you could perhaps show me how these characters/words actually look like (Burmese script is used here, correct - hidden link?

words I translated are not displayed properly in your screenshots.

But this may be even more important - can you show me (links or screenshots) on where exactly have you made these translations? If I put this right, you put your translations here, but they don't render properly and want to revert this back, or?

Regards,
Bruno Kos

May 27, 2019 at 6:43 pm #3900281

hlaingM

Hi,

hidden link?
This link you provided shows the unicode font which is installed in your browser.

I am attaching your screenshot. The red arrow which you circled shows the DEFAULT word press translation using the unicode font. My point is that I want to get rid of those default wordpress ready-made translations which made use of the unicode font. To answer one of your questions, you will see my translations of a word at the top left corner which belong in 5% of those joker type words that are displayed properly in browsers with any font system installed.

The green ones show my translations using a different font system (zawgyi-one) and they were ALL translated in the WPML string translation/domain-widget.

Does it all make sense to you?

May 28, 2019 at 8:55 am #3904369

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

There are other strings I did not translate, but they are the results of the default wordpress translations.

I tried translating "pm" using a string I found in one of the widget and it worked with that font. Would this solution not work?

I've activated "Translate themes and plugins using WPML's String Translation only (don't load .mo files)" back.

Regards,
Bruno Kos

May 28, 2019 at 9:50 am #3905027

hlaingM

Hi,

Yes, I already mentioned in one of the treads of this ticket that translating with WPML string translation overrode the default wordpress translations.

My question was if it is possible to totally get rid of those default translations that made use of a different font system incompatibility with the font I have been using to translate.

Thank you.

May 28, 2019 at 12:11 pm #3906717

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

My question was if it is possible to totally get rid of those default translations that made use of a different font system incompatibility with the font I have been using to translate.

The only thing that comes to my mind is to clear them from String Translation table (or from database directly) and then disabling "default" domain from auto-registering new strings. It can be either manually or through database:

https://wpml.org/forums/topic/wpml-drastically-slow-down-my-site-2/page/2/#post-3541827
https://wpml.org/forums/topic/string-translation-slows-down-page-loading-speed-2/#post-2589634
https://wpml.org/forums/topic/extra-slow-site-after-installing-wpml/#post-3561281

So to use SQL query such as:

 
DELETE FROM `wp_icl_strings`  WHERE `context` LIKE 'default'
 

Or perhaps identify these strings and then set to use those translations (depending on the number of these). I don't imagine there could be another way to do this. If you want to test any of these solutions, make sure to make a full site backup or better use a staging site.

Regards,
Bruno Kos

May 29, 2019 at 9:21 am #3913867

hlaingM

My issue is resolved now. Thank you!