This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Riffaz 2 months, 3 weeks ago.

Assigned support staff: Riffaz.

Author Posts
July 17, 2019 at 7:10 am

greensummits

I am trying to: set default site language to Slovak, but its not working, see screenshots

Link to a page where the issue can be seen: hidden link

I expected to see: Slovak language in backend and frontend

Instead, I got: English language in backend and frontend

Site default language is set in WPML->languages to Slovak, but everything is still in English. After deactivating WPML plugins, everything is correctly back in Slovak language. This was working several years without problem, now its not working.

July 17, 2019 at 7:49 am #4226707

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

What happens if you select Slovak here? hidden link

Let me know.

Regards,
Riffaz.

July 17, 2019 at 1:51 pm #4230855

greensummits

its only in my personal profile, but when I change it, wordpress is still in EN lang

July 17, 2019 at 2:25 pm #4231217

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Your screenshot shows that your default language is Slovak but as per your WP Debug info your default language is English.

This is strange.

I am discussing this with the team.
I'll update to again once we sorted out this.

Regards,

July 21, 2019 at 11:15 am #4252115

greensummits

what is status here please? page is broken and I need to fix it

July 21, 2019 at 12:50 pm #4252283

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry for the delay.

We tested your site and even with other languages your site backend in English: hidden link
It seems your site is not downloading the default WordPress translation files.

We will update you again by Monday evening regarding this.

Regards,

July 22, 2019 at 7:57 am
July 24, 2019 at 7:41 am #4271119

greensummits

after migration is complete (got an email), new site on cloudways has technical issues...

July 24, 2019 at 3:04 pm #4275957

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am checking this.

I will update again once I find the solution.

Regards,

July 24, 2019 at 3:04 pm #4275959

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

** updating status

July 25, 2019 at 5:32 am #4279179

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Did you delete this user? hidden link

Please let me a username and password to login.
The next reply is private.
This is migrated site but usernames and passwords that work in your live site should work in the migrated site.

Regards,

July 26, 2019 at 7:41 am #4287953

greensummits

no I did not delete this user, why would I do that?

there was just migration, nothing changed, when you can login to live site, you should login to cloudways site too, nothing was changed...

btw I tried to login with my credentials, still got database connection problem

July 28, 2019 at 7:12 am #4294923

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

We just found out that the MO files must be there.
Go to Dashboard > Updates and check if you see the Update translation button.
Many times, just visiting Dashboard > Updates will download the MO files.
You can also check the MO files in language folder if they exist.

BUT, the thing is we do not see the 'updates' in your dashboard: hidden link
It should look like this: hidden link

This might be because of some plugins.
If you disable the WPML and other plugins do you see the 'updates'?

And, migrated site has some issues it seems.
I am checking the and I will update again if I find anything else.

Let me know how it goes.

Regards,
Riffaz.

July 28, 2019 at 9:44 am #4295341

greensummits

I guess you are not very WordPress experienced... you cannot see Updates menu because there are no updates for plugins, everything is up-to-date. But you can go there by link:
hidden link

please can you focus on fixing my wpml problem? as I wrote before, when I disable wpml plugins, language is correct

July 28, 2019 at 10:10 am #4295387

greensummits

+ you can use newly created testing environment, so now you have everything to find the problem:
hidden link