This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Mihai Apetrei 1 year ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 26, 2018 at 8:43 pm

guillermoR-9

I am trying to: Change wordpress defualt language

Link to a page where the issue can be seen: hidden link

I expected to see: Site language to be change to any of the others I need

Instead, I got: Only english language

September 27, 2018 at 3:00 pm #2770973

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From what I understand by looking at what you wrote and the link you used, I think you want to use a different language in the WP admin panel.

In order to do that, please follow the steps in the documentation below:
https://wpml.org/documentation/getting-started-guide/language-setup/setting-the-wordpress-administration-language/

Please let me know if that is what you were looking for or if you still need help.

I will be waiting for your answer.

September 27, 2018 at 4:59 pm #2771337

guillermoR-9

This is exactly my problem when I change the WP admin language it stays only in English. I assumed this was the way WPML plugin works... The options to choose another language is there but when I change it and press save the language reverts to English.

September 28, 2018 at 8:28 am #2772896

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

For me it looks like changing your admin language works on your site.

Please follow the steps below and let me know if they work for you, too:

1. Go to Your Profile (hidden link)
2. Find the "Language" setting that is currently set to "Site Default" (I am attaching a screenshot, too)
3. Change that to what language you want from the dropdown
4. Scroll to the bottom of the page and click "Update Profile" and then wait for a few seconds while it applies that language.

Let me know if it worked.

September 28, 2018 at 1:20 pm #2773923

guillermoR-9

This one is my user language setting of how my wordpress page settings will look. But I need to change in WP -> setting -> site language. This is that is troubling me and has the only English bug.

October 1, 2018 at 12:38 pm #2778125

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Sorry, I thought you were talking about the admin user profile language.

Regarding the site language, that behavior is normal when you are using WPML because, in the moment when you go through the WPML setup, you are asked about what will be the default site language.

So you will be able to change that language from WPML > Languages > Site Languages > Change default language > here you can select the language that you want.

Let me know how it goes!