This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Laura 2 months, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
July 19, 2019 at 11:19 am #4245981

davideG-16

Hi, I would like to delete English Media Gallery (I want to use only one Gallery without copy images) - how I can do it ?

Woocommerce: I put together more products, so from single product I did variable products but at the moment I have 52 products with variants in Italian language and in English I still have 223 products... How can I sync?

Thank you
Best Regards.

July 19, 2019 at 11:45 am #4246123

davideG-16

I did it but I still have the english version with 223 products vs 52
1) Visit WooCommerce>>WooCommerce Multilingual>>Status tab
2) Choose *Troubleshooting* link(On the bottom)
3) Sync the Products(*Sync products variations* and *Sync product stock quantity and status*)

also I did it
1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

But without resolved

July 19, 2019 at 12:11 pm #4246229

davideG-16

I did sync but after refresh ...

July 19, 2019 at 1:43 pm #4246783

davideG-16

There is anyone can help me on this?

July 20, 2019 at 12:35 pm #4249859

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

Could you check if while doing the synchronization in the browser console there are errors?
To enable it, check here: hidden link open the "console" tab and run the synchronization.

Also, please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

July 22, 2019 at 8:13 am #4254739

davideG-16

Hi the situation is the same.
Sync - refresh and it's like before...

I don't understand what you want to see in "console", nothing appear...
Let me know I can I do to solve it.

July 22, 2019 at 9:16 am #4255239

davideG-16

How can I upload the debug in a private mode?

July 22, 2019 at 9:20 am #4255379

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

I'll enable a private reply. If it's long, please paste it on a place like pastebin and share only the link here.

July 22, 2019 at 12:05 pm #4256931

davideG-16

Hi Laura,
Migration hidden link Completed

Tks in advance.

July 22, 2019 at 4:04 pm #4259787

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I checked your site. You have more English products because when you grouped simple products into variable products, you didn't delete the "extra" English products. So you need to delete them.

I checked for example the "Frida" foulard, you have 1 in Italian and 4 in English. One of them is the translation of the Italian one, and all the variables are synced there. The other ones do not have a translation and you need to delete them.

The syncing option seemed to work indeed, but it won't delete products.
Please let me know if this is clear and if you still have synchronization issues once you delete the extra products.

The topic ‘[Closed] Delete english media gallery and sync product’ is closed to new replies.