This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.57 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by viktorsL 4 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 31, 2019 at 10:09 am

viktorsL

I am trying to: Delete image from media library when I am using my main website language (Latvian).

Link to a page where the issue can be seen: Internal media library page of wordpress.

I expected to see: I want to delete image on other languages aswell automatically.

Instead, I got: Image is still there when switching to other language (Russian)

May 31, 2019 at 12:19 pm #3930411

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Please follow the steps,

1) Go to WPML > Settings > Posts and pages synchronization > and check the option “When deleting a post, delete translations as well”

2) Goto Media select the default language from the top bar language switcher and try deleting a media file,

Does it help? Let me know the results

Kind regards
Raja

May 31, 2019 at 12:30 pm #3930491

viktorsL

My issue is resolved now. Thank you!