This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 2 replies, has 2 voices.

Last updated by Mihai Apetrei 3 months, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 4, 2019 at 12:41 pm #4143289

marinoB-2

I am trying to: delete the ?lang=it from the page url

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: hidden link

I followed what your staff suggested in a few previous threads but nothing worked. A the moment WPML settings are as follows:

Directory with different languages ((hidden link - Italiano, hidden link - Inglese))

and WordPress permalink is set like this:
hidden link which is the second last option in the permalink settings as I cannot choose the Custom Structure as I used to do in the past. It simply doesn't work, when I save the settings is goes back to the hidden link

Best regards,

July 4, 2019 at 3:41 pm #4145157

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 5, 2019 at 2:26 pm #4152121

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they worked.

Can you please follow the next steps:

1. Create a full website backup.
2. Clear all the cache

3. Now, let's do this:

- disable all plugins except WPML and its add-ons
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that goes and if following any of these steps solves your issue or bring any change.

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai Apetrei

The topic ‘[Closed] Deleting the ?lang=it from the page url’ is closed to new replies.