This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bruno 11 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
June 5, 2019 at 1:01 pm #3960707


I tried deleting all pages of one language from a website and followed the instrucions given here

Link to a page where the issue can be seen:
hidden link

I expected to see:
Only the posts of the selected language should be deleted.

Instead, I got:
All other languages, including the main blog language, were deleted as well.

How can I selectively delete all translations of one single language, without affecting the other languages?

June 6, 2019 at 3:50 am #3965777


Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. On the WPML > Settings > Posts and pages synchronization, make sure that the "When deleting a post, delete translations as well" option is unchecked.

Also, if the problem persists, please as a test, could you disable all non-WPML plugins, switch to the default theme and see if the problem persists?

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

Thank you.

June 21, 2019 at 10:28 am #4066273


Hi Bruno, sorry for the delay, that does not fix my issue, unfortunately.

The option was never checked. See screenshot below. Any other reasons that may couse this behaviour?


June 25, 2019 at 1:29 am #4080259


Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)


Related to WPML only this option could cause this behavior.

As a test, could you check with all non-WPML plugins disabled and with the default theme to see how the behavior will be? This may be related to some other plugin or even to your theme.

By testing this and disabling non-WPML plugins and switching to the default theme, does the problem persist?

Thank you.

The topic ‘[Closed] Deleting translated pages of ONE language deletes ALL pages’ is closed to new replies.