This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 11, 2019 at 6:23 pm #3791225

cecileB-5

Hi,

Since I installed the required plugins, I have been facing many issue, crashing down the website.

I have already tried to minimize the use of the features, but this time I am about to give up, so maybe I could find any help here ?

My theme use Elementor and when I create a page to translate an existing one from French to English, it forces the theme to display the page title while in the admin panel, it's set up to be hidden. Here is the result : hidden link
"Home" or "Accueil" should not be displayed.

The home page is already translated, but the English version is not displayed when English is chosen as language. The French version keep being displayed.

Any thoughts on how to solve the issue ?

Thanks in advance for your help.

Best,
Cécile

May 13, 2019 at 3:36 am #3794713

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

It seems like it's displaying a mixed language on the English page, some are English, some are French, most of the time this happens when all the strings aren't translated properly, so could you please let me know if those strings, posts are translated properly?

https://wpml.org/documentation/translating-your-contents/

If you translated the content properly and still it's not being displayed, It can be caused by some interfering settings, it's not possible to mention which settings probably is creating this without checking your site settings, so, for this, I would need temporary access (wp-admin and ftp) to your site.

Could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to receiving your answers so we can get to the bottom of this issue.

Thanks

May 13, 2019 at 10:55 am #3797215

cecileB-5

Dear Shekhar,

Thanks for your reply. Well, I have already solved the issue, so the strings that are not translated yet are just because I am not done with the translation yet.

However I have another issue now. When I create a new page in the original language (French), and a create an translated version in English, I update the content using the "Éditeur de traduction de WPML" available on the WP Admin Panel of the page.

Once done, I update the content and save, but the translation is not displayed while the English version is avalaible.

I have to go to the "Traduction de chaîne" WPLM panel to "update" the translations. How come ? Can I fix this ? That's really annoying and time wasting.

Thanks in advance for your help.

Best,
Cécile

May 14, 2019 at 4:28 am #3803525

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Glad to know that the previous issue is resolved.

Regarding the new issue, could you please provide me a link to that page that's having this issue so I can test it? Also, I request permission to create a new page for testing this further.

Look forward to your reply.

Thanks

May 14, 2019 at 6:49 am #3804003

cecileB-5

Hi there,
Thanks for your help. You can test the homepage as the issue is even more important on this page : only half of the content is available for translation + the translations not update automatically.
You can create a new page for testing.
Thanks,
Cécile

May 14, 2019 at 9:19 am #3805093

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you also provide me the login details so I can check this further? I have enabled the private reply for you.

Thanks

The topic ‘[Closed] Design changing + translation not displayed’ is closed to new replies.