This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by yunfeiS 5 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
May 5, 2019 at 10:45 am #3742415

yunfeiS

I translated some products withe woocommerce mutilingue, but it didn't show up in the language. In the translation jobs tab, the status is that 'Waiting for translator', and it shows that ' No translation languages configured for this user.' in the translations tab.

May 6, 2019 at 7:49 am #3745561

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

The WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

Once you did that, resave the original and the translation and see if it appears in the front end.
If not, could you tell me which kind of users do you have in Translation Management? It's only you translating or the message "No translation languages configured for this user." appears for another user? If you configure the language pairs, do you manage to take the translations?

May 8, 2019 at 2:17 am #3762995

yunfeiS

It didn't work, Just I have the translating role.

May 8, 2019 at 9:29 am #3765043

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

could you provide me credentials so I can better check the issue? If you have it, a staging site would be better.

Also please point me a couple of products/links where I can see the issue.

I'll enable a private reply.

May 8, 2019 at 3:09 pm #3768249

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

in your WPML -> Support I see your WP Memory Limit is still at 40M.
If you added the lines I sent you at the end of the wp_config.php, try adding after line 2.

Also, you can try to add yourself as translator and see if the situation improves.

May 11, 2019 at 2:14 am #3788625

yunfeiS

I think It's recovered after I modify a flie /wp-includes/default-constants.php to increase the memory limit of wordpress.
1. increase the memory limit of the wordpress:
the file : /wp-includes/default-constants.php
} else {
define( 'WP_MEMORY_LIMIT', '256M' );
2. increase the memory limit of the php
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:
/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

3. add myself as a tranlator
translation management->translation roles

After did that, I waited a long time as almost two hours, it's automatically recovering slowly.