Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by setyo-hadiJ 2 years, 1 month ago.

Assigned support staff: Otto.

Author Posts
July 19, 2018 at 1:00 pm #2534779

setyo-hadiJ

i have 2 domain already pointed to my website logamjawa.com and logamjawa.id

I also already add logamjawa.id to site management WPML

but when i change my Language URL format A different domain per language into domain logamjawa.id as my indonesia languages website said not valid and cant save.

Am I set wrong? can you assiss me.

July 19, 2018 at 1:28 pm #2534852

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Sometimes the validation throws a false positive.

If with WPML deactivated both sites points to the same site, it should be fine.

I suggest you try the following:
-Backup your site
-Uncheck the validation box
-Set the domains per language option

Let me know your results, please.

Kind regards,

Otto

July 19, 2018 at 2:14 pm #2534979

setyo-hadiJ

Dear otto

I dont understand "Sometimes the validation throws a false positive.

If with WPML deactivated both sites points to the same site, it should be fine."

but i Uncheck the validation box, then try to acess logamjawa.id. Then

warning shows up, my website not secure. whats happen?

July 19, 2018 at 3:31 pm #2535129

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

What I meant was that sometimes just unchecking the validation is enough.

And this seems to be the case.

If when you get the warning you click in ADVANCED and the proceed anyway to the site you will see that it is working fine.

The problem here is that your site is forcing https and you need a valid SSL certificate for both domains. It seems that you only have it for the English domain.

Can you please check that?

Kind regards,

Otto

July 20, 2018 at 12:17 am #2535604

setyo-hadiJ

Dear otto.

Thats because I use my domain logamjawa.id as parked domain. and I read in internet parked domain cant use ssl. very bad because i need booth of my domain have ssl and translation with WPML.

I want to try move parked domain to addon domain but without sub folder (mean addon domain with direct to public_html,

is that possible? will any problem with WPML if I do that.

July 20, 2018 at 8:27 am #2536444

setyo-hadiJ

Dear Otto,

I add logamjawa.id as a addon domain without sub folder (on public_html) problem with ssl is disapear but a lot of trouble happen.

My inbound link change to this permalink. Very weird I dont know how to set it

See images hidden link
You can check this link hidden link

July 20, 2018 at 12:42 pm #2564436

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I don't think the new domain setup is right.

When I visit: logamjawa.id, I am redirected to .com, which is not correct.

And I checked the domain here:
hidden link

And it gets a 403 Forbidden header.

I think the previous setup with a valid SSL or without forcing https should work.

I couldn't see the problem with the link, as I can't access logamjawa.id. But I don't think it is related. For support rules, we are able to handle only one issue at the time. This helps us to bring you a better service and also help other users to find all the information here exposed. For that reason I have to kindly ask you to open a new thread if you need further assistance, you can assign it directly to me. In that way, you don't have to wait and we can continue working on it.

Kind regards,

Otto

July 21, 2018 at 12:31 am #2565949

setyo-hadiJ

Dear Otto, Sorry, I dissabled WPML because i found a bug or something wrong with WPML CSS

so thats wy you not see redirection on my website.

Please check this https://wpml.org/forums/topic/wpml-disable-screen-option/ hope we can fix this and we could continue on this ticket

July 23, 2018 at 1:35 am #2568339

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks.

I replied to the other ticket. Let's put this one on hold until it is solved. Ok?

Kind regards,

Otto

July 23, 2018 at 4:22 am #2568652

setyo-hadiJ

Dear Otto, I also solve this problem. Thanks for your support.