If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Yvette 2 months ago.

Assigned support staff: Yvette.

Author Posts
September 10, 2019 at 5:28 am #4541925

hakonA

I am trying to add my 9th language to a wordpress page. When I add the new domain and validate the page the confirmation comes "valid". But when I leave the page and come back to it the domain has disappeared.
I have p.eu in English but I am trying to add p.is for Icelandic
When I create a icelandic copy of the home page it has also p.eu
Then I visit the wpml/languages and the page I just validated has is.p.eu and a domain for Icelandic.
Why doesn't p.is stick?

September 10, 2019 at 10:54 am #4544349

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

As a test, can you please create a page in IS only (no translation). Are you able to view this page within the correct domain?

Thanks

September 10, 2019 at 12:33 pm #4545327

hakonA

Hi.
no I cannot create any page with the permalink in Icelandic. I can create a page but it has a permalink to the English domain, even though it is listed under Icelandic sites.

September 10, 2019 at 12:49 pm #4545435

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Ok thanks.

1 Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

2. Could you please post the contents of your .htaccess file as well?

Thanks

September 10, 2019 at 4:25 pm #4547325

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I think there is a problem with the cnames / DNS setup on your server for this subdomain.

If everything is setup ok I should be able to view following URLS with/wihtout WPML active:
hidden link (works)
hidden link (does not work)

Please check with your server support on how you can get hidden link to work.

I wait for your feedback

September 10, 2019 at 6:24 pm #4548059

hakonA

Hi,
I don't want to use a subdomain. I'm trying to use purepasta.is

September 11, 2019 at 10:50 am #4552759

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

ok - I just reread your message and I missed that.

I suspect this has to do with the way you have setup your subdomains and your aliases. Can you please refer to this thread and confirm that you have set up the subdomain and alias domain as described?

https://wpml.org/forums/topic/using-local-domains-for-languages/#post-2783520

Notably, the p.is domain should be an alias of the main site in your DNS settings which is a different setup from subdomains.

THanks for checking this

September 11, 2019 at 2:05 pm #4553987

hakonA

Ok thanks. I will try this Parked domain method and see if it works. I only did the Add-on domain that was in mentioned in the documentation.

September 12, 2019 at 7:10 am #4558737

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Alright.

September 12, 2019 at 8:28 pm #4564323

hakonA

hi again,
It turns out that the feature "parked domain" doesn't exist in cPanel anymore. I tried the Alias feature instead but that didn't help. First it is individual and has no connection to the purepasta.eu site unless I make and redirection to purepasta.eu but that will not work.
I also cannot add a SSL to an alias in cPanel.

Should I add and CNAME record under the purepasta.eu for purepasta.is ? How?

the instructions you linked to here, I cannot get this to work.
Step 1:
Create site.fr an alias of site.com (you can use the parked domain option for this)

September 13, 2019 at 7:33 am #4566117

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

I would suggest that you contact your hosting provider to get the answer to this question as each provider does things in a different way.

They server setup / configuration details are out of scope of my own expertise. What I can tell you is that the following "test" must be successful before attempting to activate domains-per-language with WPML.

Test: with WPML deactivated, view the licesnse.txt file from all desired domains
hidden link (does not work)
hidden link (works)

You can give this requirement to your server support and they should be able to help you create the correct DNS records according to their own server setup requirements to make it work.

The topic ‘[Closed] Different domain doesn't stick’ is closed to new replies.