This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Different domain per language is not working as expected.

Solution:

Please make sure that you are configuring your server correctly.

Relevant Documentation:

https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Tagged: 

This topic contains 1 reply, has 1 voice.

Last updated by reneU-2 2 months, 3 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 31, 2019 at 1:48 pm #4314871

reneU-2

I worked with the documentation (https://wpml.org/de/2016/05/so-benutzen-sie-wpml-mit-verschiedenen-domains-pro-sprache/) and search almost every blog post, but it didn't work. I am owning a linux v-server with Ubuntu 16.04 and Plesk. I created two Domain-Aliases for the .at and .ch domain (without 301 redirect). The Server settings (apache and ngnix) are both correct. When i try to activate them in the wordpress backend, it says domains are invalid.
But if I open the domains eg. like hidden link it displays a 404 error, but with the selected language.

Can you help me?
Best regards

August 4, 2019 at 11:13 pm #4337055

reneU-2

My issue is resolved now. Thank you!