This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bobby 8 months ago.

Assigned support staff: Bobby.

Author Posts
February 13, 2019 at 11:04 am #3193482

michaelF-41

Tell us what you are trying to do?
I want to setup a different domain per language

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?
hidden link

I have nginx on Linux VPS, not .htaccess

February 14, 2019 at 1:43 am #3196647

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

if possible please review the following documentation
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

are these domains all pointing to the same WordPress directory?

what are your results with "validate on save" unchecked ?

February 14, 2019 at 8:35 am #3198164

michaelF-41

Hi, yes this document i was reading, but i cannot get over "Setting up your HTTP server" section. Maybe better will be if i give you credentials and look on it personally.

All domains are pointed to same server, i do not know if to same directory, maybe yes.

Result on validate unchecked boxes at attached.

February 14, 2019 at 9:00 pm #3201829

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Is it working now with the validate on save off? (it is ok to leave that unchecked, sometimes the validation just fails but that does not mean that everything is not set up well and it can work without the validation)

additionally regarding the step for "Setting up your HTTP server" , do you own and operate your own server ? if not you can reach out to your host server administrator and let them know that you wish to add a server alias to your current configuration.

let me know your results

February 15, 2019 at 10:34 am #3204074

michaelF-41

No, nothing work with unchecked boxes. I can send you credentials and you look on it personally. Maybe you find problem quicker.
Yes, i have own VPS, but i cannot know where should i write parameters.

February 15, 2019 at 11:23 am #3204366

michaelF-41

This is another

February 15, 2019 at 6:53 pm #3206420

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If you have not been able to set up your HTTP server then it will not work

you should be able to add this to your NGINX default folder (usually i believe there is only one where you can config even your single site server)

bellow you can find the NGINX official documentation on how to do this with a bit more information

hidden link

let me know your results once you add the server names and set up the HTTP configuration

as this is due to host set up , gaining access at the moment at your site's backend wouldnt allow me to resolve the issue as its not due to any settings within WPML but rather due to the HTTP server not being configured within NGINX

The topic ‘[Closed] different domain per language’ is closed to new replies.