This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by Raja Mohammed 5 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 29, 2019 at 5:40 pm

Julien

I am trying to: Activate "Different domain per language" with "Auto sign-in and sign-out users from all domains"

Link to a page where the issue can be seen: hidden link & hidden link

I expected to see: Credentials transfered betweeen domains

Instead, I got: When I add the new domain I get an error if I thick Validate on save, (Not valid). But the second domain work has expected. The only problem is with the option "Auto sign-in and sign-out users from all domains" even if I've disabled "Header always append X-Frame-Options SAMEORIGIN" on my apache config and rebooted the server I can't get the login to work on both domain name.

I also tried both with and without :

    define('WP_SITEURL','<em><u>hidden link</u></em>' . $_SERVER['HTTP_HOST'] . '/');
    define('WP_HOME','<em><u>hidden link</u></em>' . $_SERVER['HTTP_HOST'] . '/');

in my wp-config.php

April 30, 2019 at 9:33 am #3710111

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum,

Please make sure the Document path for hidden link is same as hidden link and your secondary domain ( hidden link) should be pointing to the same IP as your primary domain.

We have detailed documentation on how to configure the DNS for the domains please refer https://wpml.org/2016/04/use-wpml-different-domains-per-language/ .

If you are unsure or the details are beyond your area of interest please request your hosting provider for help in this case.

Once the setup is perfectly done accessing the domain hidden link should display the contents from your primary domain.

I hope this helps you better, Please feel free to write back if you need further clarification.

Kind regards
Raja

April 30, 2019 at 4:20 pm #3713569

Julien

The front end is working properly. The problem is not with the content but with the back-end. If I log into skillsinaction.ca i'm not logged in competencesenaction.ca. I already followed all the documentation from WPML and I've setup everything accordingly. I repeat, there's no problem with routing, everything work fine, I just need help regarding the authentication being transferred from one domain to the other.

May 1, 2019 at 4:25 am #3715895

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the clarification, Please help us with temporary access to your site, It will be easy for us to check the issue from our end. I have enabled private fields for you to securely share the details.

Kind regards
Raja

May 1, 2019 at 4:46 am #3715961

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Please also check whether the xframe header option is disabled in your server,

WPML uses the iframe to share the session among all domains. You need to contact the hosting support to disable an x-frame option for the secondary domain.

You can find out more information here https://wpml.org/2016/04/use-wpml-different-domains-per-language/
Please scroll to the bottom and check
Session expires while switching languages section.

Once it is deactivated please let me know whether it solves your issue.

Kind regards
Raja

May 1, 2019 at 6:11 pm
May 2, 2019 at 7:58 am #3722513

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Julien,

I am extremely sorry, I think I overlooked the issue. it's a mistake from my side. Please apologize.

I have escalated the issue to our second tier of supporters for detailed investigation. I will let you know soon once I hear from them.

Kind regards
Raja

May 3, 2019 at 4:03 am #3730617

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

For some reason, our second tier of supporter is able to access the french site and without any issues with the session. Please refer to the screenshot => hidden link

We are still checking for the possible issue, I will keep you posted.

Thanks.

May 3, 2019 at 5:23 am #3730927

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for your patience, We have tested the site in a couple of browsers and unable to reproduce the issue. This seems like a cache issue with any of the plugins or the issue is temporary for a specific browser. I would request to follow the basic debugging disable all non-wpml plugin check if you can reproduce the issue in your browser and try enabling the plugin one by one to check for the plugin which interacts with WPML and your browser.

please refer to the screencast hidden link

Kind regards
Raja