This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Solution: """"""""""""""" Usually www is a cname of the original domain. If you change your site default language (Settings > General) to contain www in front of the domain – then it should work for the second domains as well.

Also please check WPML -> Languages settings, check how we set for "Language URL format", we added www. there as well.

"""""""""""""" They have to create a redirect rule that redirects from non-www to www. This might happen with the plugin Redirection from WP repository."

RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC] RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

This topic contains 12 replies, has 2 voices.

Last updated by kennethL-7 3 months ago.

Assigned support staff: Bruno Kos.

Author Posts
July 9, 2019 at 3:22 pm #4172459

kennethL-7

I am trying to: make hidden link go to the translated version of the website eelcobaak.nl --- eelcobaak.nl is set as the Dutch URL under Different Domains per Language

If I switch it around, I more or less get the same problem: then hidden link displays the Dutch website, but eelcobaak.nl redirects back to the English version at eelcobaaklifecoaching.com

The DNS settings for eelcobaak.nl are
eelcobaak.nl A 37.60.250.203
hidden link CNAME eelcobaak.nl

Link to a page where the issue can be seen: hidden link

I expected to see: the website hidden link

Instead, I got: the English website hidden link

July 10, 2019 at 8:35 am #4177341

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me if you followed this tutorial in detail?
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

If unsure with some other things inside, can you reach out your hosting support?

On a side note, I found this thread and maybe it helps:
https://wpml.org/forums/topic/language-per-domain-not-working-with-www-alias/#post-3353645

Regards,
Bruno Kos

July 10, 2019 at 9:39 am #4177847

kennethL-7

Hi, Bruno-

1- Yes, I followed the instructions on that page. We have cPanel.

2- Yes, I found that thread too. I tried the additions to the .htaccess, but it then gives me "Too many redirections" error.

July 10, 2019 at 10:20 am #4178569

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

I will send all this information to our 2nd tier then.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

July 10, 2019 at 11:58 am #4179815

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I got this response from our 2nd tier:

"""""""""""""""
Usually www is a cname of the original domain.
If you change your site default language (Settings > General) to contain www in front of the domain – then it should work for the second domains as well.
""""""""""""""

Can you tell me tried this already? Hopefully it will be as simple.

Regards,
Bruno Kos

July 10, 2019 at 1:06 pm #4180481

kennethL-7

Hi, Bruno- I changed the main address from eelcobaaklifecoaching.com to hidden link under Settings > General.

This didn't help: when I type in hidden link to visit the NL website, I still get sent to the EN website (now at hidden link). I don't get sent to eelcobaak.nl.

July 10, 2019 at 2:56 pm #4181759

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you check now? It did not work when you first replied, but now it works, like there was some caching or delay in between. Have a look at the image - everything works properly now and it's switching me correctly even among other pages and translations.

Regards,
Bruno Kos

July 10, 2019 at 3:04 pm #4181931

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Also please check WPML -> Languages settings, check how we set for "Language URL format", we added www. there as well.

Regards,
Bruno Kos

July 10, 2019 at 3:16 pm #4182047

kennethL-7

OK, but now try going to eelcobaak.nl (without the www). This now sends you to the EN website (www.eelcobaaklifecoaching.com).

It's the same problem, but now reversed.

July 11, 2019 at 8:16 am #4187247

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Here is the feedback from our 2nd tier:

"That is normal. They have to create a redirect rule that redirects from non-www to www.
This might happen with the plugin Redirection from WP repository."

Regards,
Bruno Kos

July 11, 2019 at 1:11 pm #4190061

kennethL-7

OK, thanks, I reverted the changes to be non-www and added these lines to my .htaccess:

RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ hidden link [R=301,L]

Looks to work fine now.

July 11, 2019 at 2:02 pm #4190583

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Ok - is there anything else I can help you with? Otherwise I believe we can mark this ticket as resolved then.

Regards,
Bruno Kos

July 14, 2019 at 12:38 pm #4205557

kennethL-7

Indeed, Bruno, thanks for your help!