This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 1 year, 5 months ago.

Assigned support staff: Andreas W..

Author Posts
February 7, 2019 at 6:26 pm #3171791


Hi there,

I've only just started using WPML and I'm confused. I would really appreciate your help as I need to get the build site translated quickly.

1. In settings, in the 'Different domain per language' section, I'm trying to enter but it says it's not valid. This is why I bought WPML so that it could display a different language on different domains... What am I doing wrong?

2. How do I get to be a clone of, but in a different language?

3. Can you send me instructions of what needs to be done so that is shown when the english flag is clicked, and is shown when the french flag is clicked.

4. Have you any instructions for working with a Divi site?

5. Both above sites are build-sites so I want to be able to move them over to be hidden link and hidden link when the sites are approved by the client. Will my license still cover both sites when I make them live?

February 7, 2019 at 7:57 pm #3172010

Andreas W.

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)


Thank you for contacting WPML Support.

Please take a look into the following two documentation which should help you to configure your server for the feature "Different domain per language".

In case of any doubt please contact your hosting provider for further assistance.

When it comes to translate the Divi theme and its page builder elements with WPML you can find a detailed documentation here:

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

I would further advise to change the value for maxInputVars in your current php.ini file for PHP version 5.6.40. You are currently using the default value of 1000. Please change it to at least 3000. The php.ini file is located on your server. Your host provider should be able to assist you with this task in doubt.
In case you site appears to be slow I could also advise you to update PHP to its latest version and repeat the changes for maxInputVars again in its respective php.ini file.

Please follow the instructions and let me know if you need any help with translating your site.

Kind regards