This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by Andreas W. 6 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
January 10, 2019 at 3:34 pm

veroniqueR

I am trying to: change the url structure to A different domain per language but it spins forever and I can't save the change. I made sure that WPML is updated to the latest version but the problem remains.

Link to a page where the issue can be seen: apogeetrailers.com/wp-admin

I expected to see: I expect to be able to enable the A different domain per language functionality

Instead, I got: the spinning icon

There's an error message in the WPML support tab saying that the WP memory limit is 40M instead of 128, but I specified 128M in the WP config file : define( 'WP_MEMORY_LIMIT', '128M' );

January 10, 2019 at 4:17 pm #3077025

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for contacting WPML Support.

Your currently provided debug information does show a WP-Memory Limit of only 40M. You may confirm this by going to WPML -> Support and verify your current value at the section Info / WordPress. Could you please confirm your actual WP-Memory Limit?

In case your changes to WP_Memory did not take affect it might be that there is an active block for this setting on your host´s side. In order to change this limit please contact your hosting provider and let us know if this solved the issue.

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Kind regards
Andreas

January 14, 2019 at 2:38 pm #3088151

veroniqueR

Hi, I doubled checked with the hosting, and they says that the memory is not limited to 40M (see php limits info attached).

January 14, 2019 at 4:59 pm #3088943

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

Please take a look at WPML -> Support and you will find the same values as provided by your hosting provider with one exception. I am referring to the WordPress memory limit, which has currently a value of 40M on your site.

Could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 512M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Please let me know if this solved your issue.

Kind regards
Andreas

January 14, 2019 at 5:27 pm #3089152

veroniqueR

Hi, this line had already been added in the wp-config wihtout any effect. I doubled-cheked that it was really added correctly. (see screen capture attached).

January 14, 2019 at 10:02 pm #3089828

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you for your message.

I just logged into your WP_admin section again and verified your current config at the section WPML -> Support. In fact your WordPress is still running with a WP_Memory_Limit of 40M for which it is very possible that your hosting provider needs to approve those settings. Please contact them and ask for changing your WP_Memory_Limit to 256M.

Once this is completed please let me know if your site is loading as expected.

Kind regards
Andreas

January 16, 2019 at 3:54 pm #3098416

veroniqueR

I doubled checked with the host. Here' what they told me again : "We are not limiting the memory usage to 40Mb."

January 16, 2019 at 7:03 pm #3099180

veroniqueR

Ok, now the WordPress memory limit show 256M in the support tab of WPML. Unfortunately, that didn't fix the problem. I still can't enable the one domain per language parameter (it spins forever).

January 16, 2019 at 7:54 pm #3099305

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Could you please have a look at the following documentation and verify that your server has the proper configuration to run this option? You will find detailed instructions for DNS and HTTP servers from a member of our support staff.

https://wpml.org/2016/04/use-wpml-different-domains-per-language/

While checking the site for errors the following came up:

"Failed to load resource: the server responded with a status of 403 (Forbidden)"

I would kindly ask you to verify your server settings or to contact your hosting company for assistance.

Kind regards
Andreas

March 29, 2019 at 7:40 pm #3494573

veroniqueR

Hi, We moved the site to a new host to solve the problem. However, now I get an error message even with using different directories: It looks like languages per directories will not function. Details

This can be a result of either:

WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file
How to fix
When WPML accesses hidden link it gets:
cURL error 28: Connection timed out after 10000 milliseconds

The expected value is:
<!--hidden link;

I added the required code into the htaccess file and changed the permissions of the entire directory to read and write but the problem remains. I tried to switch to using a different domain per language but I get a "not valid' error message.

March 29, 2019 at 7:54 pm #3494635

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you please verify if your .htaccess file includes AllowOverride none. If so please add/amend to AllowOverride All.

Example:
<Directory /var/www/site/example.com/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
</Directory>

Please also do not hesitate to contact your Host Provider to assist you with these settings, as they are server related.

Let me know if this solved the issue.

Kind regards
Andreas

March 29, 2019 at 8:09 pm #3494671

veroniqueR

I don't see anything with the AllowOverride in the htaccess file. Should I ad it? if so, where?

March 29, 2019 at 8:40 pm #3494823

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

If the entry is not there please add it.

You can refer yourself to the example in my last message.

Are you able to locate a section named:

<Directory var/www/site/apogeetrailers.com ...

The code snippet should be added beneath this line.

Please, also do not hesitate to ask your Host Provider for assistance as some host providers might set limitations in regards to the server configuration.

Kind regards
Andreas

March 30, 2019 at 11:47 am #3498169

veroniqueR

I cannot find anyhting starting with <Directory

I'm pretty sure it's not the host limiting something as I have several others websites using WPML in this account without problem... With this site, not only i get an error message in wpml, the English menu is showing on the French version (that's why we caught the error message in WPML).

April 1, 2019 at 3:27 pm #3509671

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for you message.

Please have a short look at the following documentation.

hidden link

The issue is most likely server related. Please consult your host to verify the server settings for this domain.

I would also like to ask you to to run the site in minimal setup to see if the issue persists.

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

The topic ‘[Closed] Different domain per language option not working’ is closed to new replies.