This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by Bobby 4 months, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
May 24, 2019 at 2:43 pm

robinM-14

I am trying to have two different domains per language.

German --> hidden link
English --> hidden link

Both domains are hostet at one.com. I´ve followed the tutorial here: https://wpml.org/2016/04/use-wpml-different-domains-per-language/
DNS forward is acivated through one.com function (similar to A record to the HTTP server IP). The configuration of the settings and the permalinks of the pages seem to be valid.

Link to a page where the issue can be seen: hidden link

I expected to see: English news page at hidden link and German news page at hidden link

Instead, I got: not possible to switch between the pages. When directly heading to the German site hidden link it reverts to the English page

May 24, 2019 at 2:46 pm #3885787

robinM-14

pictures to post above 😉

Thanks!

May 24, 2019 at 6:35 pm #3887067

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i did a quick redirect check and it shows a 302 redirect active on your URL
are you using a plugin that might cause this redirect ? or maybe through your server?

hidden link

HTTP/1.1 302 Found
Cache-Control: max-age:600, public
Content-Length: 166
Expires: Fri, 24 May 2019 18:32:50 GMT
Last-Modified: Fri, 24 May 2019 18:22:50 GMT
Location: hidden link
Date: Fri, 24 May 2019 18:22:50 GMT
Content-Type: text/html; charset=utf-8
X-Varnish: 395872386 391219304
Age: 296
Via: 1.1 varnish (Varnish/6.1)
Connection: keep-alive

hidden link

May 26, 2019 at 4:35 pm #3892075

robinM-14

Dear Bobby,

Thank you for your fast reply!

I´ve cross checked and there was a redirect plug active on the wp installation of the ....de domain when I started this support ticket. Sorry for that!But I´ve deactivated the plugin already on Friday evening and was hoping that it got resolved. But however it seems to be still not working.

When I look at the DNS settings of the one.com server that hostes our domains ( ...de and ...com) I´ve tried to add a A record as explained in the guide. However, the settings could not be applied because they´ve recognized that I wanted to redirect to a domain that one.com was hosting, too. Therefore they force me to use their internal forward. Please refer to the pictures in attachment.

When I go to the language settings page of WPML, I can see that the settings for alnguage URL are valid (same as already shared picture from initial post).

Do you have any ideas? Thanks in advance!

BR Robin

May 27, 2019 at 8:12 pm #3900757

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

thank you for providing me with the screenshots !

The urls are valid but due to the redirection the .de is not accessible

if possible please contact your host provider and let me know their feedback regarding this issue as this might need to be resolved on the hosting level as it is not caused by a bug within WPML and the settings within WPML seem to be correctly added.

your hosting provider should at least be able to shed a light on the reason there is a 302 redirect on the URL and clear it if possible from their side.

May 31, 2019 at 3:09 pm #3931485

robinM-14

I´m in touch with the host provider. They seem to be unable to set up an A record of a self hosted domain...

Then I would need to move the domain to a different provider and hope that this will do the trick.

I´ll get back to this thread if I get the final response from one.com

Thanks for the moment!

May 31, 2019 at 5:01 pm #3932325

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I will leave this thread open , in the case of it closing automatically by our system please feel free to re open a new thread and assign it or ask to be assigned to me as i am aware of the details of the issue

June 3, 2019 at 5:37 am #3939413

robinM-14

Dear Bobby,

I´ve now moved the DE domain to a different host (1&1 IONOS), but the redirection seems to be still active. How is this possible?

I´ve deactivated the redirect plugin of the DE wordpress installation, then deleted the plugin, then deleted all files on the server and moved the DE domain to a different host? What else can I do? I´m kind of stuck. Any help is much aprreciated

Best regards,
Robin

June 4, 2019 at 6:43 am #3948453

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Robin,

i have checked the validation of the domain and it comes up as non valid additionally when i try to access it its not working at the moment

please verify that it is pointing to the same WordPress enviroment as the default domain

June 4, 2019 at 10:50 am #3950487

robinM-14

Dear Bobby,

Thank you for your assistance!

The support from 1&1 has resolved the strange 301 redirection. Now I´ve done all settings according to the tutorial (link above) e.g. added an A record to our IP, namely 46.30.215.16, but it seems not to redirect to the harmonic-design.com. In the preview window of 1&1 it looks like the DE domain to be still active on a one.com domain. Or is it wrong setting up the A record?

I´ve also tried to use the standard forward function of 1&1. Then the COM homepage appears at the preview window but the WPML plugin doesn´t accept the settings.

Any ideas? Thanks in advance!

best regards,
Robin

June 4, 2019 at 7:18 pm #3954863

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

please try the following test to make sure that WPML is not causing an issue here.

1. Deactivate WPML and check if both domains point to the same site.

with WPML deactivated , do you get the same site out of both URLs ?

if yes then please update me here

2. If they do not please provide the document here to your hosting service so they can better help you as they need to set it up from their side. Unfortunately we are limited to what we can do from our side when it comes to hosting

=> https://wpml.org/2016/04/use-wpml-different-domains-per-language/

June 5, 2019 at 9:48 am #3958627

robinM-14

Dear Bobby,

Thanks again for the input!

It seems that one.com cannot provide an IP adress of the server because multiple domains are hosted on the same server and their internal references are not able to relink correctly...

The only solution would be to move the whole webspace incl emails etc to another provider. But this is too much effort for the moment.

Therefore we´d like to switch the 3rd option: language as added parameter (hidden link - German). This works for the home page but if I´m within a subpage e.g.

hidden link

and then click on any link (picture) I´ll be forwarded to the correct page but reverted to English language. This happens at all pages when I click on a hyperlink within avada builder elements.

I´ve made a quick test with the first language option: Different languages in directories ((hidden link - English, hidden link - German)) with the same behaviour.

Any thoughs?

Thanks in advance

June 5, 2019 at 9:55 pm #3964263

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

if you go to hidden link and test the first product by clicking on the image it should work as expected.

this is happening because the links within your page builder are not including the correct permalink

for example go to edit the above page and within the page builder click on the image and edit
then add the URL link and search for the page you want to link, this will add the correct link including the language parameter within it as shown in my screenshots

let me know your results please

June 6, 2019 at 6:34 pm #3971479

robinM-14

Dear Bobby,

Thanks for the hint.

I was assuming that the Plugin automatically adjusts the links that they point to the correct language depending on the selector. I had to manually relink all link with the correct DE permalinks on all pages and then neccesarily update the EN translation with assigning all links again. This took me a complete day!

However this does the trick for now, but on one page (hidden link) I again find a strange behaviour:

The two builder elements on the right should link to either software or accessories. They do in case of the DE site but not for EN. I´ve checked all settings, even in string translation they have the correct translation active. I even removed both links, saved the German page, updated the EN translation, then both links were removed. After that I inserted the links again through builder element (as discribed from you above) and now the wrong EN links are back online.

How can this happen?

Best regards,
Robin

June 6, 2019 at 9:27 pm #3972179

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

The column URL was set to the wrong URL , not sure how this could of happened but i have re set it to the correct URLs and its working as expected now

please verify and update me