This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Itamar 9 months ago.

Assigned support staff: Itamar.

Author Posts
August 19, 2019 at 10:25 am #4415187


I am trying to: Just want to have the same design over the translated and the orginal language page.

Link to a page where the issue can be seen: hidden link

I expected to see: What I get on my normal pages - hidden link

Instead, I got: The demo logo, changed fonts, big white line on the footer where my footer copyright is and several other differences.

August 19, 2019 at 12:26 pm #4415933


Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)


Thank you for contacting WPML Support. Please clear all sorts of caches in your site plugin cache (W3 Total Cache) / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

If still issue persists, please follow these steps in order to isolate the cause of the issue:
- Backup your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see which one there is an interaction issue.

Please let me know the results, Thank you

August 23, 2019 at 1:54 pm #4447893


The issue wasn't resolved following all of the above steps.

The support of my theme replied with:

"Most probably your issue is because you have set to have the Theme Options of the theme to be translatable by WPML.
Because the Theme Options are set to be translatable for each language you can have separate Theme Options and in the Russian translation the Theme Options are blank.
You can add your custom Theme Options for each language again or you can make the Theme Options to be excluded from WPML so it can be the same for all the languages. (I’m not sure if this the correct option because probably some text field in theme options need to be language specific)"

I can't seem to find such an option in WPML

August 25, 2019 at 8:28 pm #4455099


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)


Noman is not available today, so I'll continue to handle this ticket. I hope that it is alright with you.

It might be that the options that the theme support told you about can be found in WPML -> Settings. Or at the bottom of the editing screen of each page in the Multilingual Content Setup section.

It seems that you are using a child theme. Therefore I cannot know which theme you are using.
Can you please tell me which theme you are using and send me the link to the website of your theme?
Is your theme officially compatible with WPML?
Please try to find it on the list that we have here.
Please also explain to me how you are translating your pages.
Sometimes screen-shots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.


August 27, 2019 at 9:32 am #4464355


Hey, here are the settings of WPML.

What I'm using is ForexOptions child theme of PokaTheme3.

The developers recommend WPML as a translation plugin for their theme, however it isn't in the list you've sent.

hidden link
hidden link

The way I'm translating is - I'm simply clicking on the + for the topic I need translated and pasting the translated content.

I can provide admin access to the site if you need it.

I tried playing around with the settings - nothing changed.

August 27, 2019 at 2:42 pm #4467795


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)


We might be looking here at compatibility issue. I couldn't find anything in our internal documentation about the Forexoptions theme. It is not known to us. I'll first try to help you by checking things on your site. But if I will not succeed, we will need to move to check the theme on a fresh WordPress installation.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:


- - Please make a backup of site files and database before providing us access. --


August 28, 2019 at 9:00 am #4472581


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've checked things on your site and found a way that might help keep using the Forexoptions theme. First I duplicated all the existing images in WPML -> Settings -> Media Translation. Please see the attached screenshot mt-settings.jpg. More about translating media with WPML at the following link.

Then I've translated the English page into Spanish. Here is how I did that.

1. On the editing post of the original English page, I duplicated the post into Spanish.
More about the duplicating content at the following link.

2. Then I edited the Spanish post and pressed the "translate independently' button.
Please see the attached screenshot trans-inde.jpg

3. Then I could edit the text and add translation (I only added Spanish at the beginning of some elements.

Now the Spanish post looks like the English post. Please see the attached screenshot es-like-en.jpg

We have extensive documentation on our site. Please use it to learn how to work with WPML.

I hope that this information is helpful to you.


August 28, 2019 at 9:21 am #4472731


Hey, Itamar
Thanks for the quick reply.

The main problem I have is the top right Logo of the website in English version and the Logos of the translated versions being different as well as the end of page widgets and copyright information appearing as a blank space.
Also the Font changes drasticly on translated pages.

On a translated page it instantly swaps to the default logo of the theme instead of my own one I intend to use.

August 29, 2019 at 3:05 pm #4482107


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)


As I've mentioned in a previous reply, the Forexoptions theme is not officially compatible with WPML, and we are looking here at a compatibility issue. So to debug this issue further, I created a test website with a clean WordPress install. You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)
Could you please install the Forexoptions theme and see if the issues are replicable on a clean WordPress installation?
Please configures WPML as it is configured on your site.
Please also make sure that you are installing the latest version of the theme.

The issues that you have mentioned that we will check are the following.

1. The top right Logo of the website is not changing on the translated pages.
Please let me know where you are adding the logo to the site.

2. End of page widgets and copyright information appearing as a blank space.
Please add a screenshot so I can understand exactly what you are refiring to.
The following documentation might help you to make the widgets show on the translated pages. Please review the documentation.

3. The fronts on translated pages are different.
Please add some screenshot so I can understand exactly what you are referring to.


The topic ‘[Closed] Different languages ignore my CSS & Logo and the website becomes disorted’ is closed to new replies.