This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 4 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 23, 2019 at 7:19 pm #3878993

michaelY-2

The site is newly setup with latest version of WP 5.2.1 on default theme and WPML plug-in: WPML Multilingual CMS 4.2.6 & WPML String Translation 2.10.4.

I have added Traditional Chinese as additional language in the website with English as default.
I changed the Language URL format to "Different Languages in directories" and I got an error "HTTP code: 404 (Not Found)"

However, I have checked that the site and should conform to the requirements: install in root; Permalink change to Post Name; URL rewrite on; .htaccess config OK.

When I access the URL: -
hidden link

Result in a blank page with the following content, not 404: -
<!--hidden link;

Please note that same server is hosting all other four sites with same setting and they are all OK.

May 23, 2019 at 7:50 pm #3879239

michaelY-2

I am not sure if it is a false alarm. As I have created several test pages, they can be displayed with my selected "Language URL format" : "Different languages in directories" and "Use directory for default language".

e.g. The following two pages can be correctly displayed:
hidden link
hidden link

But the error message still exists! Also, only able to create a "root page", but cannot specify a root "html file" (with 404: not found error). However, hidden link is OK.

May 23, 2019 at 8:25 pm #3879341

michaelY-2

I just note the following issue of WPML checking of this site:

Error message shows that:
********
When WPML accesses hidden link it gets:
HTTP code: 404 (Not Found)

The expected value is:
<!--hidden link;
********

However, the actual result in a blank page with the following content:
<!--hidden link;

May 24, 2019 at 12:12 am #3879935

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 24, 2019 at 8:41 pm #3887461

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. The error message with your languages in directories setup seems to be a false positive. You will notice the following:

1 - hidden link properly returns a blank page with the following url: <!--hidden link; in the page source. See: https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/#how-wpml-determines-if-it-can-enable-languages-in-directories

2 - It is possible to access your translated posts properly, for example: hidden link

Please, make sure to add 'SecFilterEngine Off' to your php configuration file in order to enable WPML to properly make 'fopen' calls when accessing the validation url.

Please, let me know if it helps. Have a nice day.

May 27, 2019 at 9:17 am #3895209

michaelY-2

The translated pages can be accessed, such as
hidden link

Configuration checked as advice, but error message is still there. As long as it is a false positive, I may just leave it. Thanks.

May 28, 2019 at 4:56 pm #3908971

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. If everything is working properly then you can simply ignore this message. Please, feel free to get in touch if you see any additional issue. Have a nice day.