This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Shekhar Bhandari 5 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 16, 2019 at 4:17 pm

alexanderS-117

I am trying to:
After migration staging environment to other staging on nginx I faced with permalinks problem.
Message what I see in WPML settings page:


It looks like languages per directories will not function.	Details

This can be a result of either:

WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file

When WPML accesses <em><u>hidden link</u></em> it gets:	
<head/>
The expected value is: 
<!--<em><u>hidden link</u></em>;

Also, redirect from homepage to language homepage doesn't work. The default EN language is hidden. On previous staging redirects from homepage to language homepage works well ( / -> /sv/)

I expected to see: no warnings, working redirect

Instead, I got:
Errors in setting field, not working redirects from homepage

April 17, 2019 at 4:25 am #3627113

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

I just checked your issue and it seems despite the message, the directories are working properly, which indicates that it must be a false warning. So could you please check if the English language is working properly despite the message?

Regarding the redirection, I can see that it's working perfectly now, so is the issue resolved?

Look forward to your reply.

Thanks

April 23, 2019 at 10:36 am #3662147

alexanderS-117

But why I see this text in Language URL format settings area?

It looks like languages per directories will not function.	Details

This can be a result of either:

WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file
How to fix
When WPML accesses <em><u>hidden link</u></em> it gets:	
<head/>
April 23, 2019 at 11:32 am #3662999

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

It seems like a false warning. I have noticed on a few sites the error message is still shown but the functionality works without issues.

To debug and find why there is a false warning on your site, could you create a testing site (if possible) and share us the login details?

I have enabled the private reply for you.

Look forward to your reply.

Thanks

The topic ‘[Closed] Different languages in directories NGINX’ is closed to new replies.