This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by marwanA-5 3 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
June 29, 2019 at 6:01 pm #4112727

marwanA-5

Tell us what you are trying to do?

I'm trying to use the option in language url format "Different languages in directories",

but when I try to use the language switcher to switch to the secondary language which is English nothing happens and it does not switch.

when I try to use the switcher in another page other than the homepage for example a product page it works and switches to the another language.

Is there any documentation that you are following?

https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

What is the link to your site?

Here it is: hidden link

Also have a look in the uploaded image, it doesn't show what is the error, instead it shows just a blank white box.

June 30, 2019 at 6:18 pm #4114741

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Maybe you are getting this warning as a false alarm because of the compatibility issues with server configuration. Have you completed the translation of the Homepage to English?

Please try the following steps and make sure you are getting the expected result or not.

1) Visit WPML>>Languages
2) Save the Language URL format settings(just resave)
3) Visit Settings>>Permalinks
4) Resave the settings

--
Thanks!

Bigul

June 30, 2019 at 6:51 pm #4114801

marwanA-5

Hello Bigu, Unfortunately this solution didn't work, the strange part of this issue is that if I tried to use the language switcher (either if it's the top bar switcher or the footer switcher) for the homepage it doesn't switch,

but once I choose any random page to be the homepage instead of the actual homepage and I try to use the switcher after it no longer becomes the homepage it works well.

So Once I set it as the homepage in reading settings the switcher doesn't work even if it was working before I set this page in the reading settings.

Hope that this explaining help getting a solution to the problem.

Thanks.

July 1, 2019 at 6:12 am #4115717

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

July 1, 2019 at 7:03 pm #4121945

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login details. But I am getting the following error while login. Please check.

The username or password you entered is incorrect.

--
Thanks!

Bigul

July 2, 2019 at 5:57 pm #4129217

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can log in to the site now. Have you changed the default language of the site from English to Arabic? Because the homepage is created in English and it is translated to Arabic. Please check the attached images.

Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

July 2, 2019 at 6:01 pm #4129275

marwanA-5

Hello Bigul , just before sharing the debug log I have a important point to mention it.

Yes I changed the default language from English to Arabic because I want when someone visit my site it starts with the Arabic Language not English that's why, so if it is causing the issue, is there a better way to do this rather than changing the default language from English to Arabic?

Thank you

July 2, 2019 at 6:38 pm #4129437

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Normally changing the default language will not be an issue. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

--
Thanks!

Bigul

July 2, 2019 at 6:43 pm #4129489

marwanA-5

Hello Bigul, Unfortunately I tried this but it didn't solve the issue, still when I click the language switcher to switch to English in the homepage it doesn't do it.

Shall i go ahead with the debugging or there's another solution to try?

Thank you.

July 3, 2019 at 9:22 am #4133883

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have a request. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

July 3, 2019 at 1:28 pm #4136881

marwanA-5

Hello Bigul, Yes you can go ahead and use the duplicator plugin.

Thank you

July 4, 2019 at 7:23 am #4140685

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. The Duplicator free plugin is not working on your site, it is showing *Host Build Interrupts* while creating a package. The result was the same after a few tries. Please check the attached images for more details.

Then I tried with Duplicator Pro plugin and it works well. Will debug the issue further and get back to you soon. Please wait.

--
Thanks!

Bigul

July 4, 2019 at 11:12 am #4142629

marwanA-5

Hello Bigul, Okay then take your time, waiting for the good news.

Thank you.

July 5, 2019 at 9:22 am #4149535

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, it looks like the issue is happening because of the caches. I was able to reproduce the issue initially on my local server. But it works now after I deactivate and activate all the plugins.

So please do the following steps and let me know your feedback.

a) Backup your site first
b) Deactivate all the plugins that are not related to WPML
c) If the issue is gone, activate the plugin one by one and make sure the issue is existing or not.

--
Thanks!

Bigul

July 7, 2019 at 11:05 am #4157629

marwanA-5

Hello after deactivating the plugins and activating again the issue is no longer exists, thank you for your help Bigul!

Kind Regards.