This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I would like to have different page builder elements display on my homepage in the second language. How can I translate the page to do this?

Solution: Go to WPML -> Translation Management -> Multilingual Content Setup and in the first section, change the settings to manual translation. Now when you edit the translated page, you should see the native WordPress editor.

This topic contains 6 replies, has 3 voices.

Last updated by vishalit 1 year, 5 months ago.

Assigned support staff: Lauren.

Author Posts
May 3, 2018 at 12:01 pm #1956558

adcR

I am trying to: give to homepage for english a slightly different layout then the dutch homepage.
We are using WPBakery as a pagebuilder. For the english homepage i want some blocks removed and a differtent header image.
When i set is for the english homepage, it works fine, until i try to edit the dutch homepage (or even just re-save it)
The the layout and translation is lost and the english homepage gets overwritten with the dutch version

Link to a page where the issue can be seen: hidden link (dutch language) and hidden link (english)

I completely removed all caching, also from server (except default nginx settings).
I tried different pages for the homepages, but got the same behaviour.

May 4, 2018 at 1:35 pm #1975961

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

When you created the translated homepage, did you use the Duplicate feature? If so, it could be that the pages are still synced. Edit the translation and click "Translate Independently" and see if this resolves the issue.

Also, are you using manual translation or the translation editor? You can try using the manual translation if you aren't already. To do that, go to WPML -> Translation Management -> Multilingual Content Setup and in the first section, change the settings to manual translation. Now when you edit the translated page, you should see the native WordPress editor.

Please let me know if you need any further assistance and I will be happy to help.

May 4, 2018 at 1:49 pm #1976204

adcR

Hi, Thanks for the reply.

Manual translations is set already.
And i can edit both pages using WPBakery in the backend.

When i edit the english version all is good, but when i edit the dutch (default) homepage then the english homepage content is overwritten.

May 4, 2018 at 3:15 pm #1978277

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

May 7, 2018 at 8:35 pm #2020640

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending the Duplicator files. I was able to set up a copy of your site and see this happening on your existing homepage. I tested creating a new page and adding some dummy content was not able to replicate the issue. I wanted to copy and paste the code of the existing page to a new test page, but the Text/View buttons do not appear on your page edit screen. Are you using a plugin or some code to hide those?

Please test this on your live site. Create a new page with some dummy content, and if possible, try copying and pasting the content from the text editor of the homepage. If you create a new page, translate it, and then update the original, are you seeing the same issue?

May 8, 2018 at 6:53 am #2024153

adcR

Very interesting... done this 4 times before, but now somehow it works.
But now i think of it, i think it was before i switched to manual translation.

I don't know but it seems to be working now.

Thank you very much!

July 17, 2019 at 2:04 am #4224811

vishalit

when i translate home page to English , layout of the page is changing. can you help