This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by nikolaosA-2 2 weeks, 1 day ago.

Assigned support staff: Bobby.

Author Posts
October 2, 2019 at 2:38 pm

nikolaosA-2

Hi there.
I am trying to translate my webpage and I found out that the logo of the translated page is not the same with the original.
I mean the wordpress site logo.

The theme I am using has 4 sections for the logo image. (Logo image, Retina Logo image, Transparent Logo Image, Transparent Retina logo image)

the main website is using the logo image as default but the translated page uses the transparent one (its like the translated page is considered being served to a transparent device)

Can you please let me know what is happening? Please do NOT make any change to the website.

I am sending you user login details for the website so you can see the translated page as it is hidden right now.

I also want you to delete my previous ticket as I accidentally added the login info to the post. Its this one: https://wpml.org/forums/topic/different-logo-displayed-in-translated-site-than-original/

Thanks in advance,
Nick Athanasoulas

October 2, 2019 at 6:53 pm #4682831

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

Thank you for the access details, unfortunately I am not able to review the backend as I am not assigned an administrator role.

I did, however, inspect the front end and the logo is the correct logo but what seems to be different is the menu/header settings.

Please try the following:

1. Go to your Theme Options
2. Click on the language switcher in the top header and open the secondary language in a new tab
3. Review the settings for both languages as it seems your theme accepts different settings per language in the theme options.

Let me know your results, please.

October 2, 2019 at 9:02 pm #4683253

nikolaosA-2

I checked all theme options as requested and I can confirm that all the settings are identical in original and secondary language.
What can I do next?

October 2, 2019 at 9:10 pm #4683263

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for updating me!

What about your home page settings? Usually, some themes will allow changing the settings of the menu/header styling from within the edit page.

1. Edit your home page
2. Use the language switcher and switch to the translation (open in a new tab)
3. Compare the default language and translation, are there any differences?

If you examine the source code you will notice that the English version is using the "darkheader" class

header header-v1 header-v1-only clearfix header-transparent darkheader

compared to the Greek version that is not

header header-v1 header-v1-only clearfix header-transparent 

adding "darkheader" at the end resolves the issue which points to the theme settings for the Greek version as this would be controlled by theme options.

October 2, 2019 at 9:33 pm #4683351

nikolaosA-2

I see that all settings are the same.
I changed the user role I shared before with you and now it is has admin rights.
So please login and take a look.

Thanks in advance

October 2, 2019 at 11:56 pm #4683489

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

The issue should be resolved now.

To resolve I did the following steps:

1. Edit your home page
2. Use the language switcher and switch to the translation (open in a new tab)
3. Scroll to Page Settings->Header Column
4. Set transparent header color -> dark

October 3, 2019 at 6:19 pm #4690673

nikolaosA-2

Thanks a lot!

October 3, 2019 at 6:24 pm #4690747

nikolaosA-2

My issue is resolved now. Thank you!