This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Pablo 2 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
July 26, 2019 at 1:10 pm

Pablo

I am trying to:
Copying the photo gallery from the PL version to the EN version.
In the admin panel, the order of photos in the PL and EN versions is the same.
The order is different in the EN version...

Link to a page where the issue can be seen:
hidden link - PL
hidden link - EN

July 26, 2019 at 6:34 pm #4291341

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Just to make sure, the English page backend is showing the correct result for ordering of Image. But on the frontend of the site English page is showing the image in a different order, am I right?

Are you using the ACF codes in theme files for listing images? If so can you please share the code you are using for a better understanding.

--
Thanks!

Bigul

July 26, 2019 at 9:33 pm #4291937

Pablo

Polish page -> correct.

ACF:
array(
'key' => 'field_5aad0bb2d2ec0',
'label' => esc_attr__( 'Gallery Images', 'fotonia' ),
'name' => 'mt_gallery_images',
'type' => 'gallery',
'instructions' => esc_attr__( 'Add gallery images', 'fotonia' ),
'required' => 0,
'conditional_logic' => 0,
'wrapper' => array(
'width' => '',
'class' => '',
'id' => '',
),
'min' => '',
'max' => '',
'insert' => 'append',
'library' => 'all',
'min_width' => '',
'min_height' => '',
'min_size' => '',
'max_width' => '',
'max_height' => '',
'max_size' => '',
'mime_types' => '',
),

array(
'key' => 'field_5ab0fb4c4a007',
'label' => esc_attr__( 'Gallery Template', 'fotonia' ),
'name' => 'mt_gallery_template',
'type' => 'select',
'instructions' => esc_attr__( 'Select the gallery template', 'fotonia' ),
'required' => 0,
'conditional_logic' => 0,
'wrapper' => array(
'width' => '',
'class' => '',
'id' => '',
),
'choices' => array(
'mt_gallery_masonry4' => 'Masonry 4 Cols',
'mt_gallery_masonry4_fs' => 'Masonry 4 Cols Full Screen',
'mt_gallery_12cols' => 'Grid 1-2 Cols',
'mt_gallery_3cols' => 'Grid 3 Cols',
'mt_gallery_3cols_fs' => 'Grid 3 Cols Full Screen',
'mt_gallery_4cols' => 'Grid 4 Cols',
'mt_gallery_4cols_fs' => 'Grid 4 Cols Full Screen',
),
'default_value' => array(
0 => 'mt_gallery_masonry4',
),
'allow_null' => 0,
'multiple' => 0,
'ui' => 0,
'ajax' => 0,
'return_format' => 'value',
'placeholder' => '',
)

July 28, 2019 at 8:14 am #4295081

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following steps after site backup and make sure you are getting the expected result or not.

1) Open hidden link post for edit
2) Scroll down to *Multilingual Content Setup* widget(on the bottom of the page)
3) Click on *Show system fields* link
4) Choose *Copy* as translation option for *_mt_gallery_images* and *_mt_gallery_template* fields
5) Apply the changes
6) Update the post and its translation(just resave to refresh the translation settings)

Please check the attached images for more details.

--
Thanks!

Bigul

July 28, 2019 at 9:54 am #4295359

Pablo

No change...

July 29, 2019 at 12:18 pm #4299533

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

July 29, 2019 at 12:31 pm #4299609

Pablo

I allow.

July 29, 2019 at 6:11 pm #4302753

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the permission. I made a Duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

July 30, 2019 at 4:02 pm #4309533

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

The issue is existing on my local server copy after the initial checks. But I am not able to reproduce the issue exactly in a fresh installation. Please check the following links for more details.

hidden link

hidden link

hidden link

So I have forwarded the details to our second tier team for the expert opinion. We will get back to you soon. Please wait.

--
Thanks!

Bigul

July 31, 2019 at 7:36 am #4312319

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Please try the following steps after a full site backup and make sure you are getting the expected result or not. I am getting the expected result on my local copy after these steps.

1) Activate WPML Media Translation plugin
2) Activate Advanced Custom Fields Multilingual plugin
3) Sync the Media files to English from WPML>>Settings>>Media Translation
4) Update the Polish portfolio posts(just resave to refresh the translation settings)
5) Update the English portfolio posts(just resave to refresh the translation settings)

The issue is happening because of the meta data sync issue. ACF Multilingual and WPML Media Translation plugins will help to you sync it correctly. You can install these plugins from Plugins>>Add New>>Commercial tab.

Please check the attached images for more details and let me know your feedback.

hidden link

hidden link

--
Thanks!

Bigul

July 31, 2019 at 10:45 am #4313741

Pablo

My issue is resolved now. Thank you!