Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Alejandro 1 month, 3 weeks ago.

Assigned support staff: Alejandro.

Author Posts
September 3, 2021 at 11:58 am #9518141

chrisG-6

Tell us what you are trying to do?
Translate using the Advanced Translation Editor with a consistent editor shown when the edit links in a product page (we're using WooCommerce) are clicked. Currently a different editor is shown for German than for French (base language is English)

Is there any documentation that you are following?
No, other than clicking the edit button which results in getting a different editor depending, seemingly, on language.

From the editor, going to Language panel > Translations > click cog icons for translation

I have login details and an example of how to reproduce but this ticket seems to be public...

This results in a different editor for French and German which is not what I would have expected...

Can you help at all?

Best wishes,
Chris

September 4, 2021 at 12:38 pm #9523915

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello there!

Please do the following so you completely deactivate the classic editor:

1) make sure you have the correct translation roles setup in WPML > Translation management > Translation roles (translation manager + translator for the correct roles if you are trying to translate from outside WPML > Translation management)

2) Go to WPML > Settings > How to translate posts and pages > Select to always use the advanced translation editor, in the section "what to do with already translated content"

3) Go to the page that opens in the classic translation editor and add a character to the title (or any change to a native WordPress field)

4) Save the page and then update the translations

-----------------

the reason why you saw the classic translation editor was because of one or a combination of the following:

- You didn't have the correct translation roles setup
- Your site lost sync with ATE (you can sync it in WPML > Settings > How to translate posts and pages > Sync translators and translation managers)

Try it out and let me know how it goes.