This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by stephaneG-21 1 week, 6 days ago.

Assigned support staff: Bruno.

Author Posts
October 3, 2019 at 8:06 am #4685559

stephaneG-21

Good morning

Yesterday I made the update of WPML and now I notice a lot of troubles.
My website is in French, English and Spanish, French is the default language.

Here is the list of my problems:

1 - My French and Spanish shop pages are empty (hidden link and hidden link)
2 – In the back office/pages the mention “page boutique” in grey beside the title of the page disappeared when I look the French pages but I can see it beside the shop page in the English pages (note that WPML is always configurated with French by default)
3 - I found 2 others French and Spanish pages at different URL (hidden link and hidden link). This 2 pages work well
4 – When I am for example on this page hidden link (a page that is working well) and that I use the flag to change for the Spanish page, I arrive on this page hidden link that is not working
5 – In the back office, when I click on the link “visit the shop” I arrive on the English shop but it should be the French shop

For the moment I didn’t notice more troubles but it is urgent to find a solution to restore the right URLs.
Thank you for helping me.
Karine

October 3, 2019 at 7:25 pm #4691053

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Have you looked at how URLs are set in WooCommerce > WooCommerce Multilingual > Store URLs?

Perhaps only the translation of the URL has been lost. Looking at this perhaps, just by editing these slugs the problem should be solved.

Thank you.

October 4, 2019 at 9:10 am #4694331

stephaneG-21

Hello Bruno

Do you mean here (see attached)?
If yes, no, the translation has not been lost. And it's not normal that the original language is the English because the default language is the French.

October 4, 2019 at 9:11 pm #4698605

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. Yes, I was referring to this image you posted.

>>> And it's not normal that the original language is the English because the default language is the French.

This may vary depending on which language was initially used to register strings. You can see the slug language in Settings > Permalinks. On this page, you can change the default language of the slugs or the slugs itself.

Also, you can re-save the permalinks (Settings > Permalinks) to see the permalinks will be reset and the URLs will then work again.

If the problem persists, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

October 7, 2019 at 5:27 pm #4709641

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thanks for the credentials. When I try to access your site using these credentials, this error message appears: ERREUR : identifiant non valide. Mot de passe oublié ?

This looks like the credentials are incorrect. Please, can you check? If necessary you can edit your private message above which will be displayed highlighted.

Thank you.

October 8, 2019 at 8:22 am #4713105

stephaneG-21

Yes sorry, now it should be ok.

October 8, 2019 at 3:16 pm #4716777

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. I can now access your site. I fixed the problem by following the steps below:

- Click on the WooCommerce > Settings > Products
- Click on the Save changes button (did not need to change any options)

Could you please check if your site is working properly? Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

October 8, 2019 at 3:27 pm #4716827

stephaneG-21

Hello Bruno

It works! Thank you very much !!!
Have a good day

October 8, 2019 at 3:28 pm #4716835

stephaneG-21

My issue is resolved now. Thank you!