This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 2 voices.

Last updated by Dan 7 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 1, 2018 at 9:48 pm #2779559

Dan

I am trying to:

See the lists of posts in Translation Management to be able to put posts into the Translation Basket. When I go to the "Translation Dashboard" under "1. Select items for translation" it shows me all the pages. I then change "Page" to "Post" and press the Filter button. This usually does not work initially. It just returns to the same view of pages - as if nothing was done.

I have tried repeating the process - and sometimes on the 3rd or 4th time I then see the list of Posts. Other times I have changed the type to "Post" and the "Translation Priority" to "Required" - or to "Optional". Sometimes this has resulted in the list of Posts. Other times I still wind up back on the list of pages.

Once I do get to the list of Posts, it generally stays there and I am able to select posts for the translation basket.

It's quite frustrating as it seems like it should be easy to switch. In fact, I would expect Posts to be the default.

Could there be some setting we have set wrong related to Posts?

October 1, 2018 at 10:13 pm #2779596

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Try to filter by posts and check if there is any error in the Javascript console of the browser.
- If there is no error then I kinldy ask you to activate the debug mode following the steps provided in this link (https://codex.wordpress.org/Debugging_in_WordPress) and let me know if there is any error message in teh debug.log file.

Looking forward to your answer.
Best regards,
Carlos

October 2, 2018 at 1:06 am #2779732

Dan

Carlos,
Yes, I'm seeing the following messages in the Console in Firefox:
----
Source map error: TypeError: NetworkError when attempting to fetch resource.
Resource URL: moz-hidden link
Source Map URL: browser-polyfill.js.map[Learn More]

JQMIGRATE: Migrate is installed, version 1.4.1 load-scripts.php:9:542

Loading failed for the <script> with source “hidden link.
----

In Chrome's Javascript console, I only see:

----
JQMIGRATE: Migrate is installed, version 1.4.1
----

Are any of these "errors"? In the Firefox messages, the "bam.nr-data.net" is for our New Relic monitoring that we are doing. Perhaps I should try turning that off?

October 2, 2018 at 4:03 pm #2782228

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

Yes, please, turn this off for a moment and double check if the issue persists.

Looking forward to your answer.
Best regards,
Carlos

October 3, 2018 at 3:27 pm #2785084

Dan

Carlos,

Instead of turning it off, I went to a staging server where the WordPress setup was all the same, except the New Relic monitoring was NOT running. Unfortunately, the issue still existed. 🙁

A member of our IT team is now investigating whether there is a caching issue involved. It seems there is a redis cache in front of the wp-admin section of the site - and we are thinking perhaps because the changing of the filtering is happening in Javascript, the URL doesn't change... so the caching server is sending back the old info.

Have you seen caching cause anything like this in the past?

October 3, 2018 at 3:33 pm #2785091

Dan

Carlos, One more data point - we turned the Redis caching server OFF for a bit but that did NOT fix this issue. It still did not filter correctly.

October 3, 2018 at 6:42 pm #2785485

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I would like to ask you to apply this fix in the site and let me know if it solves the issue: https://wpml.org/forums/topic/att-george-botsev-issues-with-second-language-when-using-redis-object-cache/#post-1455026

Looking forward to your answer.
Best regards,
Carlos

October 5, 2018 at 5:36 pm #2791441

Dan

Carlos,
One of our developers tried that fix and it unfortunately didn't do anything.
Dan

October 5, 2018 at 7:53 pm #2791605

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,
Thank you very much for your feedback.

I would need a sites snapshot if possible.
We usually recommend the free Plugin “Duplicator” for this porpoise.

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the installer file and the zipped package you downloaded.

★ Duplicator Instructions: hidden link

Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

❌ IMPORTANT ❌
Remember to create or keep an admin account for me before creating the snapshot, or I won’t be able to login. You may delete the new admin account once the snapshot has been built.

I will enable your next answer as private so you can provide me the information securely.

Best regards,
Carlos

October 5, 2018 at 9:13 pm #2791706

Dan

Carlos,

We _think_ we may be closer to identifying an issue with Redis. We've been able to run our site on a local development server without Redis running - and had no problems. We're now working with our hosting provider to see what we can do on our production server. I will let you know the outcome, probably on Monday.

Thank you,
Dan

October 5, 2018 at 9:42 pm #2791748

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,

I'm glad to hear that you isolated the cause of the issue 🙂
I will be waiting for your message.

Best regards,
Carlos

October 10, 2018 at 9:38 pm #2805891

Dan

FYI, we are continuing to chase down the fix. We do believe it is with the Redis server. We thought we had a fix today, but it didn't work yet. We're still investigating. I will update this ticket when I have more info.

October 11, 2018 at 1:09 am #2806079

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,

Thank you very much for keeping me updated.

Regards,
Carlos

October 12, 2018 at 5:55 pm #2812870

Dan

Carlos,
None of our fixes work. We tried disabling all plugins on our staging server and re-enabling them. We *thought* there might be a conflict with Gravity Forms as when we enabled that on staging this WPML problem started happening again. However, we disabled Gravity Forms on our production server and still had the issue.

It still feels like a caching issue, because the "Filter" button does not change the URL at all, which makes me think a cache is sending back the wrong results. However, we disabled all of the Redis caching in front of our site and STILL had this issue.

Anyway, I think we now need to proceed down the path of getting you a site snapshot so that you can investigate. We have the instructions from before and can pursue doing that.

Dan

October 12, 2018 at 7:43 pm #2812999

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,
Thank you very much for this detailed explanation.

I have set your next answer private so you can provide a Duplicator copy of the site. Please exclude the media folder and the cache folder as there aren't needed for testing purposes.

Looking forward to your answer.
Best regards,
Carlos