This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 2 voices.

Last updated by Dan 3 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 15, 2018 at 7:17 pm #2818580

Dan

Carlos,
Thanks - you should now have by private reply a duplicate copy of our site info as requested.

To recap some of our testing to date. We have tried all of the following tests. In all cases we still had issues, although sometimes it did work for a few tries and then stopped working. The tests:

- Redis disabled
- Theme was deactivated to default 2017
- WP Rest API is set not to cache
- Deactivated all related plugins
- All ISOC related plugins disabled

This was above all the other testing earlier in the thread. We look forward to any solutions or suggestions you may find.

Thanks,
Dan

October 16, 2018 at 4:40 pm #2821839

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,
Thank you very much for sharing a copy of the site.

I downloaded the Duplicator package but I wasn't able to install it on local. I keeps throwing an undefined error in the last step.

Is it possible for you to create a test site with this copy of the production site and give me access?

Looking forward to your answer.
Best regards,
Carlos

October 16, 2018 at 7:34 pm #2822257

Dan

Carlos,

We have set you up with access to another server. Can I please send you a private message with login info?

Dan

October 16, 2018 at 8:11 pm #2822323

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,
Thank you very much!

I have set your next answer private so you can provide the credentials in a secure way.

Best regards,
Carlos

October 16, 2018 at 8:24 pm #2822335

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,
Thank you for sharing this credentials.

I will take a deeper look at the test site and I will try to isolate the cause of the issue.
I will get back to you as soon as I have an answer.

Thank you very much for your patience.
Best regards,
Carlos

October 16, 2018 at 8:28 pm #2822349

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,

I just flushed the cache memory and tried to reproduce the issue but the translation manager filters the post types correctly with no errors in the JS Console of the browser.

I tried this several times and it keeps working correctly.

Could you double check if the issue persists when log in the site using incognito mode in the browser?

Best regards,
Carlos

October 16, 2018 at 9:22 pm #2822451

Dan

Carlos,

It seems we will need to give you access to our production server, as we are now not able to replicate this consistently on our staging server. However, on our production server, I *am* consistently having the problem, using both a regular and private/incognito window.

Please initiate another private message so that I can send you the credentials.

Dan

October 16, 2018 at 9:34 pm #2822456

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,

This behavior points to the production site's environment as the culprit.

I have set your next answer private 🙂

Regards,
Carlos

October 17, 2018 at 2:21 am #2822849

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,
Thank you for the credentials provided.

I was able to reproduce the issue on the live site. The first thing I noticed was the Nginx Cache, if you flush the cache created by this plugin (and the server side if exists) and the Autoptimize cache, does the issue persists?

Also I recommend you to follow this steps:
- Go to WPML -> Support -> Troubleshooting link -> Click from 'Clear the cache in WPML' button to 'Fix post type assignment for translations' button.

Note: Please don't forget to create a full backup of the site before the steps above.

Looking forward to your answer.
Best regards,
Carlos

October 17, 2018 at 7:55 pm #2825824

Dan

Carlos,

Two updates:

1. We tried changing the settings in "WPML -> Support -> Troubleshooting" and that had no effect.

2. We *are* now getting the error consistently on our staging server. You can login to that site using the credentials we supplied earlier and try making any changes you want (including deactivating plugins).

Thanks
Dan

October 18, 2018 at 1:18 am #2826116

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,
Thank you very much for this message,

I will take a deeper look at the staging site and I will get back to you as soon as I have an answer.

Best regards,
Carlos

October 18, 2018 at 2:07 am #2826189

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,

In the staging site I followed this steps and the issue seems to be solved:
- Deactivated all plugins
- Activated WPML plugins
- Applied WPML's troublshooting options
- Activated the plugins one by one.

Could you confirm that the issue is solved?

Regards,
Carlos

October 20, 2018 at 12:51 am #2833240

Dan

Carlos,

We had to wait until a time when traffic was very low on our production server to make this change. We did so tonight and after going through this process, the issue *DOES* seem to have been solved.

HOWEVER... in the past we noticed that the problem would appear after a period of time. So we want to monitor it over the weekend and on Monday to see if the problem re-appears.

We also examined the monitoring we are doing with NewRelic and found some Redis activity that we are curious about. We have contacted our hosting provider to see if they can provide any insight.

I will let you know on Monday whether all is still working and if the problem is truly resolved. Thank you for your help with this. Dan

October 22, 2018 at 4:49 pm #2839034

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Dan,

I will be waiting for your feedback. Thank you very much for keeping me updated.

Best regards,
Carlos

March 7, 2019 at 8:00 pm #3286759

Dan

Carlos,

I apologize for not providing an update back in October. We had a number of other activities going on and this particular issue had to be de-prioritized.

However, we STILL have this issue of not being able to change the content type on the Translation Management page. When we go there and switch the drop-down menu from "Page" (which seems to be the default) to "Post" (or any other content type) and press the "Filter" button, the page comes back showing us the list of pages and the drop-down is reset to "Page".

We have updated our production server to WordPress 5.1 and WPML 4.2, so we are running the latest versions of all software.

What we have found is that we can reproduce a workaround solution:

1. Disable the Redis object cache.
2. Wait some period of time for Redis to no longer answer. (we monitor with another tool)
3. Go to Translation Management
4. Choose a different content type and press the Filter button.
5. Select the posts, add them to the Translation Bucket, and go through the whole process of sending them off to the Translation Service.
6. Once all that is completed, go back and re-enable the Redis object cache.

While that "works", it is NOT an easy process and does not allow our translation process to work smoothly.

Given that this particular ticket is marked as "Resolved", we will open a new one for further support.

Thank you, Carlos, for all the help you gave us before.