Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bobby 2 years, 9 months ago.

Assigned support staff: Bobby.

Author Posts
February 23, 2018 at 3:18 pm #1527687


I am trying to:
I am trying to disable language switcher a page Vezal, cause we are still developing translations...
I am also trying to change the look of the switcher on Photon site.

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
On the first I want switcher to be hidden at the moment.
On Photon I want spaces to be gone so there is "slo / eng".

For Vezal I looked at
tried the css
and was thinking of editing icl_language_selector in functions.php in my theme folder, but I can't find it...

February 23, 2018 at 9:05 pm #1527951


Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)


On how to Disable the language switcher.

1. You can go to WPML->Languages->Language switcher and click on the "trash" icon.
this will remove your language switcher, you can just add it again when the site is ready.

2. On the same page scroll down and you can Hide the languages that you are currently working on that are not ready yet.

3. To disable the switcher on only specific pages and have it enabled on other pages will require custom CSS

For Photon spaces :

It is important to note that WPML make the feature of the language switcher available and provides you with a few basic options such as color, dropdown, horizontal, etc. but the overall look of your switcher in the front end is fully controlled by your theme

you can override this with some custom CSS added either in additional CSS within languages page or your theme's additional CSS within theme options

custom work is outside the scope of your support but i can provide you with a quick and simple solution to start you on the right direction (note that i cannot tailor the solution or go in details)

 .wpml-ls-legacy-list-horizontal a span {
    vertical-align: middle;
    margin-left: -29px;

February 23, 2018 at 9:57 pm #1527976


Hi, for Photon we have solved it, thank you!

But for Vezal I still have problems... in WPML->Languages-> I don't have any trash icon.
Also I have "Language switcher options", "Menu language switcher", "Widget language switcher", "Footer language switcher", "Custom language switcher" but not just Language switcher...

February 23, 2018 at 10:14 pm #1527977


Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Glad to hear that !

How did you assign the language switcher ?

It should be under the menu language switcher.

if you never added it and it was automatically added then the switcher was added by your theme and there should be an option to disable it either from within Theme Options or from within functions.php

in order to do that i recommend contacting the theme authors as they can give you a quick script to temporary disable it.

The topic ‘[Closed] Disable and redesign language switcher’ is closed to new replies.