This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 3 voices.

Last updated by Bigul 8 months, 1 week ago.

Assigned support staff: Bigul.

Author Posts
January 19, 2019 at 9:01 am

m.K-2

Hi, I have this setting: "Disable browser language redirect". But it doesn't work. I'm in Germany and when I search for the site, it always shows me the German home page.

But I don't translate the whole website, just parts of it. So the home page will always be in English and I want everybody to go to the original language homepage withour the "/de" at the end of the URL.

I see that many people had the same problem, but the answer of the support is always different.

Can you explain for non-developers what I should do? Thanks a lot!

January 21, 2019 at 4:15 am #3110552

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

I recently tested the site on a browser where German is the default language and can see that the page doesn't redirect to "German page" so it seems like some cache issues that are showing the issue on your browser, could you please try to test this on a private browser or even on a new browser after clearing cache and let me know if this helps?

Thanks

January 25, 2019 at 9:33 pm #3130583

m.K-2

Hi,
I tested it on several desktop computers and smartphones and tablets and in private mode and after deleting the cache and Google always shows me the /de version (see screenshot).

January 28, 2019 at 4:42 pm #3136685

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Shekhar is on vacation now. So I am taking care of this ticket. Hope it will be okay for you.

Please let me know the following details to track the issue.

a) Are you using any other keywords for the Google Search than *tour van rental*

b) Are you using any server-side cache feature like Memcache

--
Thanks!

Bigul

February 9, 2019 at 6:33 pm #3178661

m.K-2

Hello,
sorry for my late reply.

I still have the same problem. I search for all kinds of things on different desktop computers, tablets etc. It always shows me the /de page. But the biggest part of my website is in English.

I don't use any cache plugin at the moment.

February 11, 2019 at 2:48 pm #3183574

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. We have released a new major version of WPML(4.2) last week. So please upgrade to the latest version after a full site backup and make sure the issue is existing or not. May you have to wait for a few days for Google to refresh the site details.

If you are still having the issue, please share the admin credentials. Now I am getting the following error while login to the site.

ERROR: The username or password you entered is incorrect. Lost your password?

--
Thanks!

Bigul

The topic ‘[Closed] "Disable browser language redirect" doesn't work’ is closed to new replies.