Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Mateus Getulio 1 month ago.

Assigned support staff: Mateus Getulio.

Author Posts
August 9, 2022 at 8:20 pm #11835869

oldrichH

Tell us what you are trying to do?
I would like to use a classic translation editor for translation page content with images, but I'm swamped with hundreds of image Titles that I have to confirm to each portfolio item that I've translated it although it is usually a numeric image file name without suffix...

Is there any documentation that you are following?
Today I studied all the WPML website including https://wpml.org/documentation/getting-started-guide/media-translation/. I had two online conversations with support, but my testing was not sufficient. I have also submitted a proposal to modify the behavior of the media translation feature. Actually this is a new behavior only since some WPML release, we didn't have this problem before. I understand that our site is absolutely extreme in this aspect, but the image names are for internal system use and there is no point in translating them on any site even for SEO reasons. "The title attribute is shown as a tooltip when you hover over the element. A title attribute is not required. What’s more, most of the time it doesn’t even make sense to add it." (hidden link)

Is there a similar example that we can see?
On every page with attached images 🙁

What is the link to your site?
Example of portfolio with unfinished translation.
hidden link

What I tried today:
The setting of switching the Title tag in the Custom fields section to "Do no translate" or "Copy" is probably not the right one. Testing the Title custom field translation deactivation was a false positive because I was testing the translation of a new page with images that were not system assigned to this test page due to being uploaded directly to this page. Therefore, the translation of the image titles was not forced.
When I tried updating the translation of the existing pages, the image names kept appearing and many translations were deleted, so I restored the entire database.

I think this feature is more governed by the setting in the "Post Types Translation" section using the "Media Files (attachment)" item. However, it is not possible to make settings for individual fields there. In database the field is stored into post_title field is generated from post_name field.

We are also thinking of having the whole website translated into another language and the idea of paying for translation of nonsensical names of tens of thousands of images is not entirely pleasant...

We would need a change solution for new and existing translations.

Image 2022 44 09 001.png
Image 2022 22 09 001.png
August 11, 2022 at 2:08 pm #11851103

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thanks for your contact. I'll do my best to help you!

Just to keep you updated, we are already checking this issue and trying to find possible solutions for you. As far as I can see, other users already reported a similar behavior:

https://wpml.org/forums/topic/marking-media-title-and-alt-text-as-not-translatable/
https://wpml.org/ru/forums/topic/отключить-автоматический-перевод-image-title/

The first case is escalated to our developers. On the second case, there is a workaround, but it works only if you do not intend to translate the medias. But it seems to not be your case, correct? You want to keep translating the images, alt attributes, and exclude only the titles, is that right?

Please confirm this information to us, and I'll be checking with our second tier supporters what we can do here. Thanks!

Best regards,
Mateus.

August 11, 2022 at 4:43 pm #11852065

oldrichH

"The first case is escalated to our developers."

Thank you, we will wait for an update before processing the next language translation.
We want to use image translation, but in a meaningful way, only visible caption and description for ALT text for images that have filled text. So this is the same probably as you first case, I apologize for missing it.

August 11, 2022 at 8:24 pm #11853019

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

No worries, and thanks for the clarifications!

In this case, duplicating the media titles to the translations wouldn't be a possible workaround? You could automatically do that by running the Media Translation setup again in WPML -> Settings -> Media Translation.

Regardless, I have escalated this ticket to our 2nd tier of support where our 2nd tier specialists will take a deeper look at this issue and will try to find a solution.

I will get back to you as soon as I get an answer from them. Thanks for your patience in the meantime!

Best regards,
Mateus.

August 15, 2022 at 8:54 pm #11868917

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello again,

Thanks for your patience.

Could you please show us some examples of the images containing this issue? Also, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 23, 2022 at 10:35 am #11911353

oldrichH

Hello,
I don't understand at all:
In this case, duplicating the media titles to the translations wouldn't be a possible workaround? You could automatically do that by running the Media Translation setup again in WPML -> Settings -> Media Translation.

What exactly are the implications of this? Will we then have to translate all the media again?

My understanding of the whole thing is that the media translation is programmed to require a title translation and cannot be configured separately. Incidentally, there was a similar problem previously with captions and descriptions being required for all images. This change was also previously initiated by me. You should probably want me on the concept team 😉

If we are solving a feature and not a bug, then why are login credentials needed? We have 17 GB of images on the site and backups are a bit of a problem. Or maybe our problem is not replicable on any installation? The condition is that the images probably have to be associated with the page you want to translate. I was hoping that in the new version of the plugin this would be ok and we would be able to specify a nonsense-free translation.

I attach at least a screebshot of the setup and a sample xliff is here: hidden link

Greetings

Image 2022 29 23 001.png
August 23, 2022 at 8:21 pm #11915739

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for your reply.

In this case, I'll provide you with an automatic login link for a Sandbox, so that you can replicate the same behavior there. Does it sound good?

Another approach we can test is:

- to disable the Media Translation plugin
- update the original language page
- open the translation again and check if it has changed anything on the media title translations

If possible, please give it a try and let us know about your results. Regardless, in my next private reply you'll find the automatic login link, in order to reproduce the issue.

Please keep us posted. Thanks!

Regards,
Mateus.

The topic ‘Disable image name translation’ is closed to new replies.