Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 3 voices.

Last updated by mmoI 5 days ago.

Assigned support staff: Alejandro.

Author Posts
November 13, 2018 at 9:34 am #2901764

mmoI

Hello,

Can you tell me how I can disable translating images in page ?

I try in to disable "image" option but that not work.

Thanks

November 14, 2018 at 7:33 am #2905573

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

First of all, I would need to understand how is your page created/how are those images added in the page (eg: if you are using any content builder), what is the page we are talking about and if you want to disable the translation of images just in this page or everywhere on the site.

Links and screenshots would help a lot.

Also, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

November 14, 2018 at 2:20 pm #2906761

mmoI

Hello,

The point "3. " is resolved. (but not the point 2. & 4.)

Thanks

November 15, 2018 at 9:44 am #2909446

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I suppose you want to use the original image everywhere on your site, but do not want to translate it, right? if that's the case maybe this will be useful to you:

WPML > Settings > Post Type Translation > Unlock the "Media" Post type > set it to "Translatable - use translation if available or fallback to default language"

The best way is to always duplicate the images, of course, bu if you don't want to do that, then you can try that option, maybe it works for your purposes.

About the URL and Slug, they are both different, they might all have the same content but the URL is handled as the entire page (Protocol + domainname + slug = https:// domain.com / your-awesome-slug) while the slug is only the last part of the url (/your-awesome-slug)

I hope this answers your questions.

November 15, 2018 at 12:47 pm #2910122

mmoI

Hello,

Ok for the diffrence between slug and URL.

Concerning the translation of image, I followed your advice but that not work. I would like just disable the translation of image name as in attachment.

Thanks

November 15, 2018 at 3:08 pm #2910544

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Oh,

The screenshot you just sent comes from the Translation editor.
If that's the case you can either disable the Media Translation plugin (WPML media) or, if you still want to keep it enabled, then you can use the Translation Management plugin for that:

Go to WPML > Translation Management > Find and select your page,
select the page but do not select the images and you will still have them there, but you won't have to translate them.

If you still don't feel like doing any of the above mentioned suggestions, then you can just leave the images as they were there and just select the checkbox at the bottom of your screen that reads "translation is complete" That should do it.

Let me know if that helped.

November 16, 2018 at 8:58 am #2912728

mmoI

Hello,

I disable the Media Translation plugin (WPML media) and I sent translation work to traductor but we see always the names images fields to translate.

It's very important that I disable the fields "images" because the translator export the Xliff files and translate it in other software.

Thanks

November 16, 2018 at 3:34 pm #2914276

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Could you tell me the steps you're taking in order to get to that section on the screenshot, please? maybe i can give you a more specific answer to your case.

Also, please remember that you have to erase all the ongoing jobs and add them again, this time the images won't be present.

To do that, please go to WPML > Translation Management > Translation Jobs > then select the ongoing jobs and scroll down to the "cancel selected".

I hope this helps.

November 16, 2018 at 4:06 pm #2914346

mmoI

I didn't do anything special.

Please see the link.
hidden link

I tried your advice for erase jobs translation but I have always the fields of images names to translate when I send.

You can see also in my backed (I sent in my one other reply the access).

Thanks

November 16, 2018 at 6:04 pm #2914539

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I think the problem is gone now, i changed the media post type to "Copy" instead of "Not Translate" and that seems to fix the issue.

If yo want to check the change you just need to go to WPML > Settings > Post Type Translation and find the "Media" element.

Can you please confirm you don't see the images anymore on your end, please?

November 19, 2018 at 9:22 am #2918766

mmoI

Hello,

Unfortunaly, I see always the image name to translate when I send the the work to translator.

Please, see this screnshot. I show you how I send the work to translator (I make this screenshot at 10:00 am 19 november (french time).
hidden link

Thank you very much for your help.

November 20, 2018 at 1:15 pm #2923287

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I believe that's the standard behaviour of the translation Management, i asked our developers aout this and will let you know as soon as i have more information on the matter.

Right now, i checked your site and the configuration is correct. I'll let you know as soon as i have more information on the matter.

November 20, 2018 at 1:19 pm #2923293

mmoI

Hello,
Ok, tell me rapidly please because I can't launch the translate now.
Thanks

November 29, 2018 at 10:49 am #2951599

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

I can now confirm the fact that the image appears in the translation management editor is an expected behaviour of the module but if you'd like, i can open a feature request for you.

I can't promise when or if it will be implemented but if it is, you'll see it in a newer WPML Translation management version.

For now, know that when the media translation module is on and the media is not selected, even though it will appear for translation in the editor, that information won't be sent to he services (to remote services, i mean), so it will not be translated and you won't be charged for that.

If you have any other question about this, let me know and i'll do my best to answer it as clearly as possible.

November 29, 2018 at 2:57 pm #2952781

mmoI

Hello,

Yes I would like that you to open a feature request. It's important for me because these image name text appears in Xliff file when we import it.

Thanks