This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Bigul 1 year, 10 months ago.

Assigned support staff: Bigul.

Author Posts
May 9, 2018 at 1:45 am #2042319

pJ

Tell us what you are trying to do?

Change autoload on SQL table to NO for: wp_installer_settings & wpml_translation_services

Can you please confirm if it safe to stop autoloading SQL wp-options query: wp_installer_settings it looks like it only is used bij toolset anyway.

Can i also disable autoload for wpml_translation_services i don't use external translators and will never start doing this..

Please verify and let me know if i can change them to autoload NO or delete them in full without messing up WPML?

May 10, 2018 at 7:28 am #2066438

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

It will be fine to disable the *autoload* in the most of the cases. Please run the following query to check the size of your autoload data.

SELECT option_name, SUM(length(option_value)) AS option_value_length
FROM wp_options
WHERE autoload='yes'
AND ( option_name LIKE '%wpml%' OR option_name LIKE '%icl%' )
ORDER BY option_value_length DESC

Also please let us know the exact reason for disabling the *autoload* option.

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

May 13, 2018 at 2:26 am #2103214

pJ

All good no error just to speed up SQL if autoload is not necessary why outload anyway? 😛

May 14, 2018 at 3:03 pm #2123591

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. It is happening because *_icl_cache* is used on every page, so autoload is using to speed up things that are loaded on every page. We planning some improvements in the upcoming versions.

--
Thanks!

Bigul

May 15, 2018 at 3:48 am #2128750

pJ

So i can disable autoload for wp_installer_settings & wpml_translation_services and it will also not bring issues later/in the long, so _icl_cache should stay on autload though?

May 15, 2018 at 1:07 pm #2139184

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have forwarded the details to our second tier team and waiting for their updates. Please wait.

--
Thanks!

Bigul

May 16, 2018 at 4:34 am #2149495

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, it will not be an issue. If you set the autoload to false and if WPML needs those option on every page WordPress will fire a single additional query and cache the results. The cache memory is going to be used in any case.

You can also disable *wp_installer_settings* and *wpml_translation_services" for now we think those are not needed on each page.

Please create a new full site backup before these changes.

--
Thanks!

Bigul

The topic ‘[Closed] Disable wp_installer_settings & wpml_translation_services’ is closed to new replies.