This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 11 voices.

Last updated by Sumit 5 months ago.

Assigned support staff: Sumit.

Author Posts
July 2, 2018 at 9:09 am #2452678

inbentaw

Tell us what you are trying to do?

I dont want to use the Media Translatin feature. It seems that now this is a core feature. I'd like to disable it so that a) My images are available in all languages (no language tags) b) My images are not duplicated when i upload them.

I have 9 languages and don't need to translate images, so i dont want to see my media files and database records increased 9 times.

Is there any documentation that you are following?

I cant seem to find information on how the media translation settings work:
- When uploading media to the Media library, make it available in all languages
- Duplicate media attachments for translations
- Duplicate featured images for translations

(i can disable all settings, but the media library is different depedning on the language you choose. I have editors in different langauges, so i'd like them to see all iamges withou having to duplicate all images)

Thanks!

July 2, 2018 at 2:03 pm #2453997

inbentaw

I'd also like to know the implications of each of these settings: which of them will create a duplicate of my files and/or database records.

thanks!

July 4, 2018 at 1:32 pm #2463293

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for contacting support forum.

It seems that media files need to be duplicated now in order to display in all languages.
However, your question is valid and I will escalate this issue.
I will let you know as soon as I have any feedback on this.

Thanks

July 4, 2018 at 1:33 pm #2463316

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Meanwhile, Can you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Thanks

July 4, 2018 at 2:31 pm #2463636

inbentaw

Thanks, just attached the debug info

July 5, 2018 at 11:19 am #2466992

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I just got the feedback that our team is aware of this problem and it will be fixed in next release of WPML (very soon).
I will update you as soon as this version is available to download.
I am sorry for the inconvenience!

Thanks

July 5, 2018 at 1:13 pm #2467452

inbentaw

Ok thanks!

August 2, 2018 at 10:26 am #2604983

Michael

This is kinda urgent for me. Any updates on this? Im managing a woocommerce store with 3000+ Products, each with about 5 images. That makes about 15.000 useless media files and database entries for each language. Thats terrible....

August 2, 2018 at 12:59 pm #2605335

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am sorry for the delay. This issue has been fixed in WPML 4.0.5
Please upgrade to latest version and let me know.

Thanks

August 2, 2018 at 10:28 pm #2607052

Michael

Well, doesnt look like its solved. When i set the Media to "not translateable", the media i upload doesnt even show up in the media library. All i want is completely disable the media translation and simply share attached media of each post/page/cpt across al languages. Same behavior as before 4.0. Is the a way to do this? Am im missing a setting?

August 6, 2018 at 1:46 pm #2616018

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am sorry for this. Yes, you are right I can see the problem.
After consulting with my team it is because we now do not set language information to media when you upload but because of this, it is not visible in media library as WPML media (some part) is now merged into WPML core.

We have a new ticket for this and I will update you again when it is completely fixed. I am sorry for the inconvenience.

Thanks

August 6, 2018 at 4:06 pm #2616652

Carl

Hi, I would like to get informed as well about this.

When set to not translatable, the media is only available in the language the media is uploaded. Same thing if you permanently delete the media, It will not been deleted from the server until you do the delete in each language. Very annoying.

It would be appreciated that, "by default", the media are not translatable like it was before that functionnality. We are at WPML 4.0, we get used to the old way, any add-on should be optional in the config.

All my websites are messed up now.

Thanks for understanding.

August 16, 2018 at 11:17 am #2649434

jan-willemK

I have this exact problem. I want to be able to just view all attachments in the Media tab. Not make duplicates, not filter on language. Just show me my media.

I understand some people have the need to translate media. But for people like me that don't need this, this change breaks my site and makes me lose media. Newly uploaded media doesn't show at all! This is a major flaw. Please advise

August 24, 2018 at 12:54 pm #2673153

Michael

Any new info on this? The current implementation ist terrible. It needs to be possible to completely disable this like before. In the current state this plugin is unusable for me and most of my customers, it trashes my server and database with unnecessary data.

PLEASE FIX THIS

September 3, 2018 at 1:34 pm #2699593

andreasP-41

Hello,

I have exactly the same problems as described here previously as the media I upload don't show up in the media library, while the older ones are still visible. This makes it very hard to work with the system. An update to the current versions WPML 4.0.6 and String Translation 2.8.6 didn't solve the issue.

If there are any settings as a workaround, I'll be happy to try them. This is a serious problem for me which has been around for 2 months now, so I would greatly appreciate any progress. Thank you.