Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by patriciad-17 4 months, 2 weeks ago.

Assigned support staff: Andrés.

Author Posts
June 27, 2019 at 12:02 pm #4099855

patriciad-17

I am trying to:
I purchased a basic WPML licence based on the information about requirement showing on WPML page https://wpml.org/documentation/plugins-compatibility/elementor/ that clearly stated I only need WPML Multilingual CMS and Elementor plugin, free or pro version, I just purchased the single site license of WPML to use the Elementor/WPML compatible translation module.

Upon installing it, it now requires me to also install WPML Translation Management and WPML String Translation extension which are only accessible with an upgrade
Link to a page where the issue can be seen:

I expected to see:
I expected to be able to use the Elementor compatible version with the basic licence

Instead, I got:
An upgrade requirement clearly in contradiction with the advertised minimal requirement

June 27, 2019 at 2:23 pm #4100771

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello there,

Welcome to WPML support forum.

I'm sorry about this misunderstanding but I'm not sure where did you get that screenshot. I just visited the link provided and the content is different (screenshot):

What you need
WPML Multilingual CMS package which includes WPML Translation Management and WPML String Translation add-ons

If you want to translate your site created with Elementor, you can try to duplicate your pages with WPML and translate them using WordPress native editor. However, we can't guarantee 100% that it will work.

Best regards,
Andrés

June 27, 2019 at 2:35 pm #4100891

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello again,

I truly present my apologies, I have continued investigating this situation and it seems that this documentation link was recently modified and you are totally right. Our intention was never to send a wrong message but just a lack of clarity as our core plugin (WPML Multilingual CMS) has the same name of our WPML Multilingual CMS package.

Thank you for bringing this to our attention, we have just modified it as you can see it. We hope that this change helps avoiding any future confusion.

Again, please accept our apologies. 🙁

Regards,
Andrés

June 30, 2019 at 10:19 am #4114015

patriciad-17

That does not solve my problem at all.
First, as the information was not up to date at the time of my purchase, the description was misleading and it resulted into considerable loss of time trying to understand why the purchased WPML did not function as advertised.
Second, apologies do not compensate at all for the loss of time - about 7 hours of searching for relevant tutorials or patches on various forums - that adds up to an amount superior to the cost of an upgrade.
Third, congratulation for fixing the content on the page, but that only solves the issue for subsequent users, not for my case.
I think that, at minimum, I should be able to receive the WPML Translation Management and WPML String Translation extension for 1 site.

July 1, 2019 at 5:26 am #4115635

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I understand your position however that is something that we can't handle in this forum as it is only for technical support.

I recommend you to write to hello@wpml.org and explain your case. They will analyze your situation and provide you an answer for your case.

Regards

July 4, 2019 at 3:45 pm #4145167

patriciad-17

My issue is resolved now. Thank you!