Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by yao-yuT 1 year, 3 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
October 1, 2019 at 1:34 am #4667907


Tell us what you are trying to do?

After downloading and activating WPML, my website started to face display problem in many pages, the previous display mode is still there when checking by backend WPBakery Page Builder, which is showed in enclosed file.

Please help fix the bug so my page can display properly as usual, thank you!

Is there any documentation that you are following?


Is there a similar example that we can see?

Example in enclosed file

What is the link to your site?

hidden link

October 1, 2019 at 11:59 am #4671815



October 1, 2019 at 11:59 am #4671817

Raja Mohammed

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

I have taken over this ticket now.

Please create a snapshot site and pass on the archive link here.

You can use the Duplicator plugin to create a snapshot of the site and share the package link with me I have enabled private fields for you to securely share the details.

October 1, 2019 at 12:03 pm #4671853


No prob, working on it.

October 1, 2019 at 12:20 pm #4671947


hidden link

October 1, 2019 at 12:23 pm #4671961


Can u reach the file? thank u.

October 2, 2019 at 7:50 am #4677569


Are u there Raja? it's been 15 hours without reply after u taking over this ticket....
thank u.

October 3, 2019 at 3:29 am #4684347

Raja Mohammed

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sorry for the delay I was away yesterday.
Im looking into this, I will update you in a while

October 3, 2019 at 7:35 am #4685177

Raja Mohammed

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your patience,

Following are my observations and suggestion

- Your site default language is set to Chinese but there are no products created in the Chinese language.

- You have set product translation setting to Fallback to default when there is no translation available, This will work only when you have products created in the Default language (Chinese)

Please follow these suggestions,
- I can see the products are created in English however I am not sure why Chinese is set to the default language. consider changing the default language to English this will solve all your issues

- If the above suggestion is not an option then follow these steps,
--- Change the product translation preference to "Translatable - only show translated items" from WPML > Settings > Post type translation

--- Delete the shop page and its translation, Remove it from the trash

--- Create a new shop page in English and translate it to Chinese

--- Goto WooCommerce > Settings > Products, Change the language to "All language" from the topbar. Choose the shop page to the one that is created in the English language

--- Once done Goto WPML > Support > Troubleshooting, Click on the following buttons
[x] Clear cache with WPML
[x] Remove Ghost entires
[x] Set language information
[x] Recreate ST DB tables

Following these steps resolved the issue in my local installation

I hope this helps resolve your issue.

October 3, 2019 at 9:19 am #4686255


Thank you Mohamned, I'll follow your steps and try today.

also for another big issue after using WPML is that massive of my images turns into ? or not displaying either backend / frontend after using WPML, for this situation, what shall I do to fix them? It was all uploaded before using WPML.

October 3, 2019 at 9:28 am #4686305

Raja Mohammed

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks, I will await your response.

Thanks again for creating a separate thread for the new issue, I have responded to the media issue in a separate thread which you have created

I would prefer to restrict the discussion of this thread only to the shop issue 🙂

October 6, 2019 at 6:18 am #4701731


My issue is resolved now. Thank you!