This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by philipmartinjones 3 months ago.

Assigned support staff: Bruno.

Author Posts
July 3, 2019 at 3:15 pm #4137839

philipmartinjones

On several pages within my site I have a list of partners. These are generated with the Blog Manager plugin (which is listed as compatible with WPML on your site). The partners are all posts with the category 'partner'.

Although these are all in 'English' I need them to show up on French and German pages, too. I don't want to make copies of them if possible, as this feels like creating a lot of duplicates.

Is it possible to configure my system so that blog posts show-up in Blog Manager lists, irrespective of the language of the post and the page on which it is being shown? Can it be done through settings or would I need to code a filter into WPML/Blog Manager?

Thanks

July 3, 2019 at 8:50 pm #4138935

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. You can try using the WPML fallback feature depending on how this plugin you are using has been made.

For this, you can follow the step by step that is in our documentation: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

By following the steps in our documentation, were you able to achieve the expected result?

Thank you.

July 10, 2019 at 9:23 am #4177713

philipmartinjones

Unfortunately this did not work as expected.

However I think this may be due to a bigger issue: I can only see the French translations when I am logged in. I have checked all the settings and of-course made sure that the language is published and not hidden.

I have seen some other support articles/posts about this subject but their advice has not helped. I am now using a staging server for testing this, so that we can eliminate potential caching issues, and also do more radical testing.

What do you suggest to help diagnose and fix this, please?

July 10, 2019 at 8:54 pm #4184373

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. This will depend on how your site was done. Initially, please, which page are you talking about? Are you talking about the blog page (hidden link)?

Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Also, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

July 13, 2019 at 2:24 am #4202173

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for your credentials. Unfortunately, I still can not understand the problem you're reporting.

Are you talking about the Blog page, which in the secondary language is not listing the posts? Can you please elaborate a little more so I can better understand?

Thank you.

July 16, 2019 at 9:34 am #4218121

philipmartinjones

Hi,

There are two problems, which may be related:

1. We have translated the homepage and a further test page into French. Although all the settings suggest they should be live on the website, they are not being displayed unless you are logged in. If you use the language selector (temporarily below the footer) or go to hidden link then you get a 404 Not Found error.

2. When you are looking at the homepage in French (by first logging in), there is a section towards the bottom of the page with the title 'Partenaires'. This should have a list of posts, generated by the plugin, Blog Manager. Again, I've followed the instructions to make the English language posts show up on French pages but they are not showing.

I think we need to solve the first problem, the most important one first. To confirm: you can do what you need to on the esstaging site for testing and fixing.

Thanks,

Philip

July 17, 2019 at 2:19 am #4224967

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Philip,

Thank you for the detailed explanation.

1. On your first question, the homepage is not displayed in the secondary language because it is as draft. Or password, the "Home Page" page has not been published in the secondary language. This is why the page is displayed only when you are logged in. I'll attach an image for you to see.

You can change this using the "Quick Edit" feature of WordPress to change the status to "Published".

2. About the second issue, you're reporting, in WPML > Settings > Taxonomies Translation, I select the "Translatable - use translation if available or fallback to default language" option for categories also.

Also, I noticed that some other elements are not being displayed, like the information below the "Partners" field. To do this, I followed the steps below:

- Click to edit the Home Page in the English
- Scroll down and look at the "Multilingual Content Setup"
- Click on the "Show system fields"
- On the "_bsf_service_" and "_bsf_post_type" options, I've selected "copy" to images and "translate" to the texts. I'll attach an image for you to see.
- Now you can translate that content as well. Content is currently in English

Please, could you check if your website is working properly?

Thank you.

July 17, 2019 at 10:00 am #4228407

philipmartinjones

Thank you. It is all working well now, thanks to your help.

Please can you ask your colleagues to update the documentation in the Translation Editor. I read a lot of articles on the WPML website before asking for help and I would never have realised that it was necessary to switch to the foreign language view, quick edit and change status to published. Or perhaps it would be better for the developers to enhance the translation manager for each page with a button to change status to published?

Thanks again,

Philip