This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.84 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am using the Divi theme (everything updated) and the link to "older entries" does not work on the divi blog module. I have isolates the issue which only occurs when my WPML-Multilingual-CMS-plugin is activated.

Solution: Going to Dashboard → WPML → Settings → Post Types Translation and selecting the Translatable - only show translated items option for both Posts and Pages will make the blog page go back to normal.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by kristianS-6 4 weeks ago.

Assigned support staff: Radu.

Author Posts
September 13, 2019 at 11:51 am #4568187

kristianS-6

I am using the Divi theme (everything updated) and the link to "older entries" does not work on the divi blog module. I have isolates the issue which only occurs when my WPML-Multilingual-CMS-plugin is activated.

The issue can be seen here: hidden link

Any suggestions to what might be causing this?

Best regards
Kristian

September 16, 2019 at 4:48 am #4576307

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Kristian,

Thank you for reaching out the WPML support!

I had a look at this element and I think that it's made to work using AJAX (since it's not reloading the page but scroll up the page and try to load more posts). In this case, can you go to Dashboard → WPML → Languages → Language filtering for AJAX operations and check the Store a language cookie to support language filtering for AJAX option, please?

Thanks,
Radu

September 16, 2019 at 5:03 am #4576315

kristianS-6

Hi Radu,
Thanks. The setting is checked and has been like that all along. I just tried un-checking it and clearing caches and checking it again, clearing caches. The problem seems to persist.

Best regards

Kristian

September 17, 2019 at 10:13 am #4587461

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Kristian,

I couldn't find some other tickets with the same issue but this is the first time to hear about this. In this case, I'll need access to the dashboard area so I can have a closer look at the way that the blog module. This way I'll be able to replicate the issue on my side and pass it to my colleagues to check it a bit closer.

The next reply is set to be private so you can safely send me the credentials.

Thanks,
Radu

September 20, 2019 at 8:11 am #4610387

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Kristian,

I checked this out a bit closer and I found that going to Dashboard → WPML → Settings → Post Types Translation and selecting the Translatable - only show translated items option for both Posts and Pages will make the blog page go back to normal. Can you check this out and tell me if things are working fine now, please?

Thanks,
Radu

September 20, 2019 at 12:49 pm #4612233

kristianS-6

Hi Radu,
That was a pretty obscure setting! It works fine now. I would never have found it myself, thank you! Best, Kristian