This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.58 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 24, 2019 at 7:56 pm

aleksisN-2

I am trying to: Edit the language versions with WordPress Divi Builder

Link to a page where the issue can be seen:

I expected to see: The top toolbar and the Divi Builder in the toolbar

Instead, I got: Nothing in the language versions (different domains).

The issue materialised after I changed the domain structure in WPML such that my Finnish translation is in smoothteam.fi, English translation in smoothteam.net and German translation in smoothteam.de. Now I am not able to edit English and German pages anymore, as the Divi Builder (and the entire top toolbar) is not visible in the language versions. It is visible in the default Finnish versions, and edits work normally there.

July 24, 2019 at 8:36 pm
July 25, 2019 at 12:57 am #4278047

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Regarding your issue, it might come from your server settings as you can read at: https://wpml.org/2016/04/use-wpml-different-domains-per-language/ under the section titled Session expires while switching languages. Please, check with your host support regarding this setting and ask them to deactivate it in case they are using this http header directive. Please, let me know if it helps, have a nice day.

July 26, 2019 at 7:42 pm #4291643

aleksisN-2

Hi! Thanks for the suggestion. I contacted the service provider, and they said the option is switched OFF already, so should not cause an issue.

The situation has changed a little in that when I log in with Chrome, I can modify the Finnish pages (but not the English and German) -- as before. But when I log in with Firefox, I can modify the German version, but not the Finnish or English.

July 26, 2019 at 9:35 pm #4291939

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I will need some extra hours to debug it into details. For today my shift is over, please, let me know if you can wait for monday so we can continue the troubleshooting efforts. Have a nice day.

July 30, 2019 at 1:10 pm #4307831

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a solution. I took a detailed look in your website and couldn't reproduce the issue, the Divi frontend editor is working properly for your different languanges and translations. Here are the steps I took to test it:

1 - In your WordPress > Pages I created a test page called 'WPML Test Page' I published it and edited it with the Divi frontend editor in the default language.

2 - I duplicated this page to the secondary languages.

3 - I visited the created page in the default language and changed to its translations using the website language switcher.

4 - I edited the english translation from: hidden link. See attached screenshot (customer_screen_english)

5 - I edited the german translation from: hidden link. See: (customer_screen_english)

Both domains and languages showed properly the toolbar and the divi builder, no issue is seen with this test page. Can you please, access your website using another network and device? Also, try creating a new test page following my workflow above and let me know the results. Have a nice day.