This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 month, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 27, 2020 at 8:34 pm #6232935

Denis Lepage

For at least the last 2 or 3 releases of the Multilingual CMS plugin (including Version 4.3.14), the Divi Builder is not properly loading when starting new pages.

We're not seeing the usual template choice page, and the Divi plugin shows the 4 rotating dots in an endless loop, against a white page. After a few seconds, the page edit opens, but instead of the Divi builder, I still only get the 4 rotating dots with no options to add components.

Divi Builder works as expected if I deactivate the Multilingual CMS plugin.

I tried to apply the correction suggested here https://wpml.org/errata/missing-support-for-divis-theme-builder/

My plugins-integration.php file contains:

// add_action( 'after_setup_theme', 'wpml_themes_integration_setup' );
add_action( 'init', 'wpml_themes_integration_setup' );

May 29, 2020 at 8:39 pm #6252835

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

June 2, 2020 at 12:42 am #6268879

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details and sorry for the bit of waiting here due the weekend. I checked your website and couldn't reproduce the issue, I created a test page 'WPML Test Page' tested it both at the backend and frontend using the Divi Builder, in all of my tests the builder worked well. If you still see any issue, please reproduce it recording your screen using this tool hidden link it will help me to understand what's going on and provide you with a solution. Thank you for your collaboration, have a nice day.

June 2, 2020 at 1:11 am #6268903

Denis Lepage

Thanks. Strange. I made 2 recordings. One is with the CMS plugin activated. I cut it short at the end, but it will keep waiting like this with the 4 rotating dots. The second video shows what happens when I deactivate the CMS plugin. Clicking on Divi builder opens the usual page with the templates.

I just found a possible work-around. With the CMS plugin activated, if I hit PUBLISH on the empty page, it seems to be giving me the divi builder correctly afterwards. I can also see your WPML test page. Divi seems to only have a problem when creating new pages, not opening up existing ones.

Where can I upload my videos?

June 2, 2020 at 1:00 pm #6274425

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In my test page I entered a title, clicked to publish it and then I was able to edit it using Divi, this is the exact same workaround you mention, I need to confirm the issue in a test server before consulting our compatibility team regarding this issue, in these cases, these are the procedures:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

The topic ‘[Closed] Divi builder not loading with CMS 4.3.14’ is closed to new replies.