This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Scott Newlands 5 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
April 17, 2019 at 6:35 pm #3634271

Scott Newlands

I have the exact same issue as this ticket: https://wpml.org/forums/topic/divi-cross-orgin-problem-using-domain-per-lang-configuration/

The main problem is with Divi Builder and using a second domain for secondary language. It does not load the Divi Builder in the front end since a recent update.

I spoke with Divi and they said to contact WPML.

Any suggestions to try?

Thank you!

April 17, 2019 at 7:43 pm #3634559

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 18, 2019 at 5:50 pm #3641351

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details provided. I gave a detailed look in your WordPress Dashboard and could replicate the issue. I forwarded your issue to our second level support, I will update you here as soon as I get some more details from them.

As regarding to make the entire ticket private we are only able to make confidential information private, such as duplicator packages, access details and so on. The reason for that is to help our customers to find solution for their issues when search our forum. Thank you for your patience and collaboration, have a nice day.

April 25, 2019 at 6:50 pm #3685211

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a reply. I would need to test your website in a local enviroment emulating different domains per language in order to determine if it is a new compatibility issue as instructed by our second level supporters. For that, please consider:

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

April 30, 2019 at 1:10 am #3707071

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Scott,

Thank you for your contined patience while waiting for a solution. I am jumping here to let you know I am still working on your issue, I will update you here as soon as I have an effective solution for you. Thank you for your understanding and patience, have a nice day.

April 30, 2019 at 2:28 pm #3712235

Scott Newlands

Thanks for letting me know! It's becoming a real problem for sure.

May 2, 2019 at 6:02 pm #3727971

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a detailed reply. I took some tests in my local environment emulating different domains per language and noticed it works properly. After a further look in your website I noticed the 'Auto sign-in and sign-out users from all domains' option from your WordPress Dashboard > WPML > Languages > Language URL format settings wasn't set and this is the reason it didn't work for you before. I checked it and now you can notice the Divi Builder works for every language as the admin session needs to be carried out for every language and not just for the default language.

You can see the builder working on this sample page: EDITED while you are logged in. Please, let me know if any additional clarifications are needed. Have a nice day.

May 2, 2019 at 7:04 pm #3728519

Scott Newlands

Hello,

I was happy to get this update from you. It still doesn't work for me though. Here's a screenshot.

You can see the URL is open but the visual builder is not active.

Any ideas?

Also can you please redact the clients URL from your message above so others users can't see it? Once we're done I'm going to request this thread be hidden too for their privacy.

May 2, 2019 at 7:05 pm #3728527

Scott Newlands

Here's the screenshot, sorry.

May 2, 2019 at 8:33 pm #3729077

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a look again and everything seems to be working as it should (see attached screenshots), please make sure to logout and login again in the page where you see the issue. Please, keep in mind the Divi Builder will only be loaded if you see the WordPress admin bar, in other words you need to make sure you are logged in, otherwise the builder won't load neither in the default or secondary languages. Hope it helps, have a nice day.

May 3, 2019 at 4:59 pm #3737079

Scott Newlands

Hello,

Thanks Marcos. Yes working now! Not sure what changed but seems fine. Can you please hide this thread now for the client's privacy? Or at least remove the screenshots and the links? Please confirm.

Thank you!

May 3, 2019 at 5:38 pm #3737283

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. All the screenshots and urls were removed, you can now proceed and mark this thread as resolved. You can read more regarding our support privacy policies at: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/. Have a nice day.

May 3, 2019 at 8:02 pm #3737719

Scott Newlands

Thank you!

May 3, 2019 at 8:02 pm #3737723

Scott Newlands

My issue is resolved now. Thank you!