Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 19 replies, has 2 voices.

Last updated by Itamar 8 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
April 17, 2019 at 1:11 pm #3631061

danielH-46

Site is default english and all the links work. Site uses tld for languages.

German site has has links to untranslated content in the german(intentionally) some of which use the page_id and some which use the english slug with the german domain.

I dont understand this behaviour. Seems to be linked to divi global and/or text module but cant work it out.

I have run sticky links and Translate Link Targets

April 17, 2019 at 7:47 pm #3634569

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I'm not sure that I fully understand the issue that you have and I need more information about it.

You wrote: "Site uses tld for languages."
Could you please tell me what do you mean by 'tld'?

Where can I see this issue on your site?

You wrote: "Seems to be linked to Divi global and/or text module but cant work it out."
Can you please elaborate on this point?
Are those links in Divi modules?
Please make sure that you are following our instruction about how to work with WPML and Divi. You can see the instructions here.
https://wpml.org/documentation/theme-compatibility/divi-builder/#translating-divi-global-items

If you needed, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Regards,
Itamar.

April 18, 2019 at 12:12 pm #3639023

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

For some reason, although I can see that my user is set to be able to see hidden language, I could not see the following German links that you sent me.
hidden link
It was 301 permanently removed.
I needed to make the hidden language visible to see this page temporarily.

Anyhow when I could finally see this page, I started to look for the problematic links. I think that I've found it. Please see the attached screenshot albanian-link.jpg
Can you please confirm that I see the problem that you are talking about?
English is the default language of your site. And I guess that you have created this page in English and then translated it into German.
Is this correct?
Can you please tell me which is the original English page?
I need to check it to understand how you have added those links.
Please also tell me the same about this page.
hidden link

Thanks,
Itamar.

April 18, 2019 at 12:24 pm #3639095

danielH-46

Correct this is the issue.

The orginal page is hidden link and the translation is
hidden link

hidden link is the source for
hidden link

I can only think that there is an issue with wpml and divi text vs divi blurb

p.s ill add your ip (185.167.109.22) to the ip exception list so you can see all the languages. (custom hack)

April 19, 2019 at 10:12 pm #3648301

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

My IP is not always the one that you added as an exception. Therefore I could not see what is happening on the translated pages. Could you please explain to me how add my IP as an exception so I would be able to see the translated pages?

So far, I could see how you insert the links in a Divi Text module, and then translate them with the Translation Editor. Please see the attached screenshots.
Are those the links that you have an issue with?
I'm not sure if links in the page_id format inside a Divi module would be automatically translated with WPML.

You have mentioned that you suspect that there is an issue with WPML and Divi text vs Divi blurb.
Could you please further explain to me where you have inserted the links in the original page (besides the links that I've found)?
Could you please point out to me which links get the unexpected results as followed?
hidden link
hidden link
The best way to show me this would be if you could send me a screenshot that points out the problematic links.

Thanks,
Itamar.

April 21, 2019 at 7:42 am #3651855

danielH-46

Hi All,

Here are the instructions to add your ip as an exception

/public_html/wp-content/plugins/wp-rocket/inc/front/process.php (stop caching)

find in the code :

if($_SERVER["REMOTE_ADDR"]=='your ip'){
return;
}

/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/request-handling/wpml-request.class.php (stops redirect)

find in the code

public function show_hidden() {

if($_SERVER["REMOTE_ADDR"]=='your ip'){
return true;
}

return !did_action( 'init' )
|| ( get_user_meta( get_current_user_id(), 'icl_show_hidden_languages', true )
|| ( is_admin() && current_user_can( 'manage_options' ) ) );
}

I need to know why some links to untranslated pages are page_id and others take the uk slug and substitute out the uk domain? It's inconsistent. The screenshot attachments in your previous reply are the example.

In page hidden link
This link
hidden link

In the translated page
hidden link
The link shows as
hidden link

but In page

hidden link
this link
hidden link
in its translated page
hidden link
the link shows as
hidden link

why do some links to untranslated pages have urls of page_id and some uk slug with target domain??

April 21, 2019 at 7:50 am #3651863

danielH-46

p.s can you make this ticket private until resolution?

April 22, 2019 at 1:16 pm #3655829

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for all the extra details.

I can see that this issue is happening with the Text module.
I've inserted the following code into WPML -> Settings -> Custom XML Configuration (tab).

        <shortcode>
            <tag>et_pb_text</tag>
            <attributes>
                <attribute type="media-url">background_image</attribute>
                <attribute type="link">link_option_url</attribute>
            </attributes>
        </shortcode>

I've done it ot make sure that the text links will work as expected althoug it suposes to be loaded from theWPML remote config file here.
hidden link
Then I've made a small change (just added a space) in the original language and pressed the 'Update' button. After that I also updated the translation. But unfurtunatly this didn't help.

I suspect that there could be cache issue or a collision with another plugin.
Could you please try the following?

1. Update the Divi Builder plugin to its latest version.

2. Clear all the cache from your site and see if the issue persists.

3. Update the page where the problem is (add something small like space or comma) and update the translation. And see if the issue gets resolved.

If the issue persists, please try our minimum environment procedure.

4. If possible get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated except WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example). If it persists then deactivate all plugins except the WPML and its add-ons and the Divi Builder plugin. Then please check if the problem persists. If it does not persist so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

P.S. FYI, links on this thread are only visible to you and to our supporters. If there is any other content that you want me to delete please let me know.

Thanks,
Itamar.

April 23, 2019 at 9:15 am #3661293

danielH-46

Ok,

Could we confirm what the designed behaviour should be?

Clearly all links within et_pb_text that point to untranslated content are using original uk slugs with language domain. However those within other page builder defined building blocks use page_id.

How is it designed to behave?

Thanks
Dan

April 23, 2019 at 9:24 am #3661345

danielH-46

This is with both sticky links and string scan fully completed.

April 24, 2019 at 11:06 am #3671883

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

To test this behavior I've created a fresh WordPress installation and installed on it WPML + add-ons and the Divi Builder. On this test site, I get the expected results. The Title Link URL of the Blurb Divi module is being translated automatically. And so does the links in a text module that use page_id. You can see my test page here.
hidden link
This is the English (default language) page, and you will be able to switch to French (Language Switcher at the footer) and see that all the links are translated automatically. There was no need to scan for links.

By the way, the Sticky Links option is not relevant in this case. It might even be the cause of the problem in this case. You can read more about it in our documentation here. https://wpml.org/documentation/getting-started-guide/sticky-links/

You can use my test site to check things.
You can access it through this link:
hidden link
Through this link, you will be automatically logged in. (If nobody logs in the test site will be available for one week from today.)
When you log in you can go to edit the test page here.
hidden link
You will be able to see that the Blurb module is working as expected. And for the Text module, you will see that I've created two of them. In the first one, I've inserted the links as you did like this:

href="/?page_id=1"

And in the second one, I've inserted the links in their original form like this:

href="<em><u>hidden link</u></em>"

Both of those way work and the translation link goes to the translated Hello World post, for example.

Can you see that WPML is translating those links correctly?

On your site, to fix this problem, I wanted to suggest you to also use the original form of the link and not the page_id form. And also disable the Sticky Links plugin after you revert all the links to their original. Please disable the cache when you try that.

Please let me know if this is working for you.

Thanks,
Itamar.

April 24, 2019 at 12:20 pm #3672631

danielH-46

It's not links to translated content that im worried about. Its links to untranslated content. If a translated page has two links( both to the same untranslated page) one link is in a button the url shows as page_id but if its in a text area it shows as {german domain}/forward slash

April 27, 2019 at 5:24 pm #3695931

danielH-46

hello?

April 28, 2019 at 4:08 pm #3698517

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and sorry for the late reply here.

I've checked things on the test site. Links to untranslated content show alright.
Please see the attached screenshot. You can see it here.
hidden link

I suspect that this problem is happening when the Language URL format is set to 'A different domain per language' as it is set on your site. I'll need to create a new test site on my local server to test if the issue is happening with this Language URL format.

I'll get back to you here when I have more information.

Thanks,
Itamar.

April 28, 2019 at 6:48 pm #3698797

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

When I test this issue on my local server with the option 'A different domain per language' (TLD), I get a 404 for the links. One link is the Blurb title link with the full URL inserted in the corresponding field. And the other link is a link in a text area of a Text module with this format page_id=xxx. So indeed there seems to be a problem with untranslated links and the 'A different domain per language' of WPML. Tomorrow I'll be able to consult our second tier supporters about this issue. I'll keep you updated here.

Thank you for your patience.
Itamar.