This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Divi code box module does not appear to translation editor.

Solution:

Add this XML code snippet to WPML > Settings > Custom XML Configuration

<wpml-config>
   <shortcodes>
      <shortcode>
         <tag>et_pb_code</tag>
         <attributes>
            <attribute>background_image</attribute>
            <attribute>background_video_mp4</attribute>
            <attribute>background_video_webm</attribute>
         </attributes>
      </shortcode>
   </shortcodes>
</wpml-config>

Relevant Documentation:

https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

This topic contains 5 replies, has 2 voices.

Last updated by Sol 5 months, 1 week ago.

Assigned support staff: Dennis.

Author Posts
May 7, 2019 at 7:57 pm #3761667

Sol

I am trying to: Translate a code box

Link to a page where the issue can be seen:

I expected to see: The code box option to translate the contents

Instead, I got: the box doesnt appear on the translate page and on the frontend the text is in its original language.

May 8, 2019 at 6:00 am #3763981

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.

Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Then, edit the page having issue. edit it on the default language.
-click 'Update'
-translate the page to secondary language.

Please let me know how it goes.

Kind regards,
Dennis

May 8, 2019 at 5:01 pm #3769431

Sol

Hello, my host updated the recommended settings. I did the change and saved and tried again, but the code-text module is still not showing up for translation (not showing at all)

May 9, 2019 at 1:41 am #3771799

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I would like to request temporary access (/wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. Your next reply will be set to private.

Maybe I'll need to replicate your site locally to continue debugging and escalate if necessary. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Please confirm if this okay with you.

Our Debugging Procedures
I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to BACKUP the site before providing us access.

Privacy and Security Policy
We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards,
Dennis

May 10, 2019 at 8:14 am #3782125

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for providing us with the access details.

Could you please add this XML code snippet to WPML > Settings > Custom XML Configuration

<wpml-config>
   <shortcodes>
      <shortcode>
         <tag>et_pb_code</tag>
         <attributes>
            <attribute>background_image</attribute>
            <attribute>background_video_mp4</attribute>
            <attribute>background_video_webm</attribute>
         </attributes>
      </shortcode>
   </shortcodes>
</wpml-config>

-edit the page on the original language.
-make a small change on any of the content blocks. click 'Update.
-undo the small change. click 'Update'
-translate the page to secondary languages.

Documentation: https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

Does it help? Please let me know.

Kind regards,
Dennis

May 10, 2019 at 5:47 pm #3787165

Sol

My issue is resolved now. Thank you!