This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Andreas W. 5 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 8, 2019 at 8:22 pm #3771027

shayanG

Hi,

I already have a translated version of my home page. I need to set that page as the Spanish version of the home page. However, when I follow the steps to do that "change language, connect translation," some of the modules from the Divi Builder disappear. I'm not sure why. Also, the trending bar at the top doesn't display a post name.

May 8, 2019 at 9:45 pm #3771355

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support.

When translating the Divi Page Builder with WPML it is highly recommended to use the WPML Classic Translation Editor or the Advanced Translation Editor.

https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

As far I can understand you tried to translate manually with the WordPress Editor, correct? Could you please go to WPML -> Settings -> How to translate posts and pages and verify if one of our translation editors is activated?

Also, increase your Memory Limit and WP Memory limit to 256M.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Kind regards
Andreas

May 9, 2019 at 4:18 pm #3778047

shayanG

Hi Andreas,

I followed your instructions and increased the memory limit, but the same this is happening where the post slider/images disappear. I also checked the WPML settings and they're correct.

Is there a way I could give you access to the site?

May 9, 2019 at 5:39 pm #3778487

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 9, 2019 at 10:00 pm #3779533

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have been debugging your site and I have to appologize for the fact, that you will need to edit the Extra theme options once more, as I deactivated the theme temporarily for testing.

As far all the strings are translated with the Classic Translation Editor, but the dynamic content for each post is not showing up, as those posts are not translated yet.

Please translate all the pages and posts and lot me know if you still experience issues.

I further synced the menu at WPML -> WP Menus Sync and added the WPML menu language switcher at WPML -> Languages.

Let me know if you got any further questions.

Kind regards
Andreas

The topic ‘[Closed] Divi Modules Disappear After Translation’ is closed to new replies.