This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Bobby 1 month, 1 week ago.

Assigned support staff: Bobby.

Author Posts
April 8, 2020 at 9:08 pm #5869909

Camila Lopez Chacon

I am trying to: Edit french versions of english pages

Link to a page where the issue can be seen: Any page in the site

I expected to see: the editor as usual

Instead, I got: a partially loaded editor that never completes loading.

Issues only appeared once we enabled domain per language. It wasn't an issue with languages in subdirectories.

Two images attached: English displaying properly, French not.

If we view in the front end, we don't get the wp menu bar at the top of the page.

April 9, 2020 at 6:50 pm #5878925

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

Please try the following:

Go to your default language and sign in through wp-admin, once done open a new tab and switch to your secondary language (The other domain) and visit wp-admin with it as well and login it. You should be prompted to log in.

Afterward, let me know your results, are you able to access the page builder?

April 14, 2020 at 6:54 pm #5907463

Camila Lopez Chacon

Hi there.

When we go to the secondary url/wp-admin, we get redirected to the primary url/wp-admin

Specifically, the primary domain is birdscanada.org, the secondary is hidden link. Trying to log into hidden link auto redirects to birdscanada.org/wp-admin.

Might there be a setting somewhere doing that?

April 15, 2020 at 6:11 am #5910023

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed I recommend taking FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose: http://wordpress.org/plugins/duplicator/

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,
Bobby

April 16, 2020 at 2:35 am #5918139

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

When WPML is deactivated the second domain should be accessible, rather it has a 301 Redirection to the main domain, see below:

hidden link

HTTP/1.1 301 Moved Permanently
Content-Type: text/html; charset=UTF-8
Location: hidden link
Server: Microsoft-IIS/8.5
X-Powered-By: PHP/7.3.1
X-Pingback: hidden link
Refresh: 0;url=hidden link
X-Redirect-By: WordPress
X-Powered-By: ASP.NET
Date: Thu, 16 Apr 2020 02:18:29 GMT
Content-Length: 152

hidden link

HTTP/1.1 200 OK
Content-Type: text/html; charset=UTF-8
Server: Microsoft-IIS/8.5
X-Powered-By: PHP/7.3.1
X-Pingback: hidden link
Link: ; rel="hidden link"
Link: ; rel=shortlink
X-Powered-By: ASP.NET
Date: Thu, 16 Apr 2020 02:18:36 GMT
Content-Length: 142912

Please review our documentation and verify that the different domains per language have been set up as expected

https://wpml.org/tutorials/2016/04/use-wpml-different-domains-per-language/

April 16, 2020 at 3:13 pm #5924709

Camila Lopez Chacon

I'm not seeing that redirection at all, neither when the wmpl is off or on. For me when it is off the English site comes up, when it is on the french site comes up (with the french url being maintained).

How were you able to generate that report? I've screencapped what I see in the Chrome network tab.

April 16, 2020 at 7:34 pm #5927051

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Try the following test please:

1. Go to Plugins and deactivate WPML
2. Now open two new tabs in an incognito window and try to access the following URLs with WPML deactivated

hidden link and hidden link

are you able to view both with WPML deactivated? When I do this test I get redirected.

You should be able to visit both without redirections with WPML deactivated.

Also verify with me that everything is set up as explained here, sometimes having your host provider verify can help find unforeseen issues as well
https://wpml.org/tutorials/2016/04/use-wpml-different-domains-per-language/

April 16, 2020 at 10:53 pm #5927565

Camila Lopez Chacon

Yeah, thats how I did it earlier. Just re-verified, no redirect. Cleared cache first and did incognito.

They self-host, I've asked their it department to verify the config.

Thank you

Simon

April 16, 2020 at 11:38 pm #5927629

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Please try now with an incognito window and let me know your results.

April 17, 2020 at 3:57 pm #5934485

Camila Lopez Chacon

I seem to be getting better results. I can edit if I go through the front end and switch language. If I switch language in the back end the editor doesn't load - so when the language and the url aren't in alignment.

Is this something you did, or something the IT guy might have done?

April 17, 2020 at 6:27 pm #5935143

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

What I did was to go to WPML->Languages->Uncheck "Validate on Save" as your URL is not validating, and enable " Auto sign-in and sign-out users from all domains"

NOTE: The "Validate on Save" option Will be checked by default once the page is reloaded, that is ok.

If I go to Pages->Edit '2020 GCB Prizes' it works fine in the default language, then I view the translation and switch to French, I am able to open the front end editor from the backend as well.

The topic ‘[Closed] Divi site: Domain per language: Editor won't load in secondary language’ is closed to new replies.